forEachProperty Method
Call a function for each property of this Entity.
forEachProperty(func: PropertyCallback, includeCustom: booleantrue): void
@note Custom-handled properties are core properties that have behavior enforced by C++ handlers.
Parameter | Type | Description |
---|---|---|
func | PropertyCallback | The callback to be invoked on each property |
includeCustom | boolean | If true (default), include custom-handled properties in the iteration. Otherwise, skip custom-handled properties. |
Returns - void
Defined in
- core/backend/src/Entity.ts Line 85
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.