ElementAspectProps Interface
Properties of an ElementAspect
Extends
Properties
Name | Type | Description | |
---|---|---|---|
element | RelatedElementProps |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
classFullName Inherited | string | EntityProps | The full name of the ECClass for this entity, in the form "Schema:ClassName" |
id Inherited | string | undefined | EntityProps | The Id of the entity. |
isInstanceOfEntity Readonly Inherited | undefined | undefined | EntityProps | A non-existent property used to discriminate between EntityProps and Entity. |
jsonProperties Inherited | { T } | undefined | EntityProps | Optional json properties of this Entity. |
Defined in
- core/common/src/ElementProps.ts Line 427
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.