ElementUniqueAspect Class
An Element Unique Aspect is an ElementAspect where there can be only zero or one instance of the Element Aspect class per Element.
Extends
Extended by
Methods
Name | Description | |
---|---|---|
constructor(props: ElementAspectProps, iModel: IModelDb): ElementUniqueAspect | Construct an aspect from its JSON representation and its containing iModel. |
Inherited methods
Name | Inherited from | Description |
---|---|---|
collectReferenceIds(_referenceIds: EntityReferenceSet): void Protected Inherited | ElementAspect | Collect the Ids of this entity's references at this level of the class hierarchy. |
forEachProperty(func: PropertyCallback, includeCustom: booleantrue): void Inherited | ElementAspect | Call a function for each property of this Entity. |
getReferenceIds(): EntityReferenceSet Inherited | ElementAspect | Get the set of this entity's entity references, EntityReferenceSet. |
toJSON(): ElementAspectProps Inherited | ElementAspect | Obtain the JSON representation of this Entity. |
is(otherClass: ): boolean Static Inherited | ElementAspect | return whether this Entity class is a subclass of another Entity class |
onDelete(arg: OnAspectIdArg): void Protected Static Inherited | ElementAspect | Called before an ElementAspect is deleted. |
onDeleted(_arg: OnAspectIdArg): void Protected Static Inherited | ElementAspect | Called after an ElementAspect was deleted. |
onInsert(arg: OnAspectPropsArg): void Protected Static Inherited | ElementAspect | Called before a new ElementAspect is inserted. |
onInserted(_arg: OnAspectPropsArg): void Protected Static Inherited | ElementAspect | Called after a new ElementAspect was inserted. |
onUpdate(arg: OnAspectPropsArg): void Protected Static Inherited | ElementAspect | Called before an ElementAspect is updated. |
onUpdated(_arg: OnAspectPropsArg): void Protected Static Inherited | ElementAspect | Called after an ElementAspect was updated. |
Properties
Name | Type | Description | |
---|---|---|---|
className Accessor Static ReadOnly | string | The name of the BIS class associated with this class. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
classFullName Accessor Inherited ReadOnly | string | ElementAspect | Get the full BIS class name of this Entity in the form "schema:class". |
classFullName Accessor Static Inherited ReadOnly | string | ElementAspect | Get the full BIS class name of this Entity in the form "schema:class" |
className Accessor Inherited ReadOnly | string | ElementAspect | The name of the BIS class associated with this class. |
element Inherited | RelatedElement | ElementAspect | |
id Inherited | string | ElementAspect | The Id of this Entity. |
iModel Inherited | IModelDb | ElementAspect | The IModelDb that contains this Entity |
isInstanceOfEntity Readonly Inherited | "true" | ElementAspect | An immutable property used to discriminate between Entity and EntityProps, used to inform the TypeScript compiler that these two types |
schema Static Inherited | ElementAspect | The Schema that defines this class. | |
schemaName Accessor Inherited ReadOnly | string | ElementAspect | The name of the BIS Schema that defines this class |
Defined in
- core/backend/src/ElementAspect.ts Line 116
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.