ExternalSourceAspect Namespace
Enumeration
Name | Description |
---|---|
ExternalSourceAspect.Kind | Standard values for the Kind property of ExternalSourceAspect . |
Defined in
- core/backend/src/ElementAspect.ts Line 145
ExternalSourceAspect Class
An ElementMultiAspect that stores synchronization information for an Element originating from an external source.
@note The associated ECClass was added to the BisCore schema in version 1.0.2
Extends
Methods
Name | Description | |
---|---|---|
constructor(props: ExternalSourceAspectProps, iModel: IModelDb): ExternalSourceAspect | Construct an aspect from its JSON representation and its containing iModel. | |
collectReferenceIds(referenceIds: EntityReferenceSet): void Protected | Collect the Ids of this entity's references at this level of the class hierarchy. | |
toJSON(): ExternalSourceAspectProps | Obtain the JSON representation of this Entity. | |
findAllBySource(iModelDb: IModelDb, scope: string, kind: string, identifier: string): { aspectId: string, elementId: string }[] Static | Look up the elements that contain one or more ExternalSourceAspect with the specified Scope, Kind, and Identifier. | |
findBySource(iModelDb: IModelDb, scope: string, kind: string, identifier: string): { aspectId?: string, elementId?: string } Static | Deprecated |
Inherited methods
Name | Inherited from | Description |
---|---|---|
forEachProperty(func: PropertyCallback, includeCustom: booleantrue): void Inherited | ElementMultiAspect | Call a function for each property of this Entity. |
getReferenceIds(): EntityReferenceSet Inherited | ElementMultiAspect | Get the set of this entity's entity references, EntityReferenceSet. |
is(otherClass: ): boolean Static Inherited | ElementMultiAspect | return whether this Entity class is a subclass of another Entity class |
onDelete(arg: OnAspectIdArg): void Protected Static Inherited | ElementMultiAspect | Called before an ElementAspect is deleted. |
onDeleted(_arg: OnAspectIdArg): void Protected Static Inherited | ElementMultiAspect | Called after an ElementAspect was deleted. |
onInsert(arg: OnAspectPropsArg): void Protected Static Inherited | ElementMultiAspect | Called before a new ElementAspect is inserted. |
onInserted(_arg: OnAspectPropsArg): void Protected Static Inherited | ElementMultiAspect | Called after a new ElementAspect was inserted. |
onUpdate(arg: OnAspectPropsArg): void Protected Static Inherited | ElementMultiAspect | Called before an ElementAspect is updated. |
onUpdated(_arg: OnAspectPropsArg): void Protected Static Inherited | ElementMultiAspect | Called after an ElementAspect was updated. |
Properties
Name | Type | Description | |
---|---|---|---|
checksum | string | undefined | The cryptographic hash (any algorithm) of the source object's content. | |
className Accessor Static ReadOnly | string | The name of the BIS class associated with this class. | |
identifier | string | The identifier of the object in the source repository. | |
jsonProperties | string | undefined | A place where additional JSON properties can be stored. | |
kind | string | The kind of object within the source repository. | |
scope | RelatedElement | An element that scopes the combination of kind and identifier to uniquely identify the object from the external source. |
|
source | RelatedElement | undefined | The source of the imported/synchronized object. | |
version | string | undefined | An optional value that is typically a version number or a pseudo version number like last modified time. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
classFullName Accessor Inherited ReadOnly | string | ElementMultiAspect | Get the full BIS class name of this Entity in the form "schema:class". |
classFullName Accessor Static Inherited ReadOnly | string | ElementMultiAspect | Get the full BIS class name of this Entity in the form "schema:class" |
className Accessor Inherited ReadOnly | string | ElementMultiAspect | The name of the BIS class associated with this class. |
element Inherited | RelatedElement | ElementMultiAspect | |
id Inherited | string | ElementMultiAspect | The Id of this Entity. |
iModel Inherited | IModelDb | ElementMultiAspect | The IModelDb that contains this Entity |
isInstanceOfEntity Readonly Inherited | "true" | ElementMultiAspect | An immutable property used to discriminate between Entity and EntityProps, used to inform the TypeScript compiler that these two types |
schema Static Inherited | ElementMultiAspect | The Schema that defines this class. | |
schemaName Accessor Inherited ReadOnly | string | ElementMultiAspect | The name of the BIS Schema that defines this class |
Defined in
- core/backend/src/ElementAspect.ts Line 145
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.