ExternalSourceAspectProps Interface
Properties of an ExternalSourceAspect that stores synchronization information for an element originating from an external source.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
checksum | string | undefined | The optional cryptographic hash (any algorithm) of the source object's content. | |
identifier | string | The identifier of the object in the source repository. | |
jsonProperties | any | undefined | A place where additional JSON properties can be stored. | |
kind | string | The kind of object within the source repository. | |
scope | RelatedElementProps | An element that scopes the combination of kind and identifier to uniquely identify the object from the external source. |
|
source | RelatedElementProps | undefined | The source of the imported/synchronized object. | |
version | string | undefined | An optional value that is typically a version number or a pseudo version number like last modified time. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
classFullName Inherited | string | ElementAspectProps | The full name of the ECClass for this entity, in the form "Schema:ClassName" |
element Inherited | RelatedElementProps | ElementAspectProps | |
id Inherited | string | undefined | ElementAspectProps | The Id of the entity. |
isInstanceOfEntity Readonly Inherited | undefined | undefined | ElementAspectProps | A non-existent property used to discriminate between EntityProps and Entity. |
Defined in
- core/common/src/ElementProps.ts Line 435
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.