SectionDrawing Class

A document that represents a section drawing, that is, a graphical documentation derived from a planar section of a spatial view. A SectionDrawing element is modelled by a SectionDrawingModel or a GraphicalModel3d. A SectionDrawingLocation can associate the drawing with a spatial location, enabling HyperModeling.

Extends

Methods

Name Description
constructor(props: SectionDrawingProps, iModel: IModelDb): SectionDrawing Protected    
toJSON(): SectionDrawingProps Obtain the JSON representation of this Entity.  

Inherited methods

Name Inherited from Description
collectPredecessorIds(predecessorIds: EntityReferenceSet): void Protected Inherited Drawing Collect the Ids of this element's references at this level of the class hierarchy.
collectReferenceIds(referenceIds: EntityReferenceSet): void Protected Inherited Drawing Collect the Ids of this entity's references at this level of the class hierarchy.
delete(): void Inherited Drawing Delete this Element from the iModel.
forEachProperty(func: PropertyCallback, includeCustom: booleantrue): void Inherited Drawing Call a function for each property of this Entity.
Drawing Get the class metadata for this element.
getDisplayLabel(): string Inherited Drawing Get a display label for this Element.
getJsonProperty(nameSpace: string): any Inherited Drawing Get a JSON property of this element, by namespace
getPredecessorIds(): Id64Set Inherited Drawing Get the Ids of this element's references.
getReferenceIds(): EntityReferenceSet Inherited Drawing Get the set of this entity's entity references, EntityReferenceSet.
getToolTipMessage(): string[] Inherited Drawing Get a list of HTML strings that describe this Element for the tooltip.
getUserProperties(namespace: string): any Inherited Drawing Get a set of JSON user properties by namespace
insert(): string Inherited Drawing Insert this Element into the iModel.
removeUserProperties(nameSpace: string): void Inherited Drawing Remove a set of JSON user properties, specified by namespace, from this Element
setJsonProperty(nameSpace: string, value: any): void Inherited Drawing  
setUserProperties(nameSpace: string, value: any): void Inherited Drawing Change a set of user JSON properties of this Element by namespace.
update(): void Inherited Drawing Update this Element in the iModel.
createCode(iModel: IModelDb, scopeModelId: string, codeValue: string): Code Static Inherited Drawing Create a Code for a Drawing given a name that is meant to be unique within the scope of the specified DocumentListModel.
insert(iModelDb: IModelDb, documentListModelId: string, name: string): string Static Inherited Drawing Insert a Drawing element and a DrawingModel that breaks it down.
is(otherClass: ): boolean Static Inherited Drawing return whether this Entity class is a subclass of another Entity class
onAllInputsHandled(_id: string, _iModel: IModelDb): void Protected Static Inherited Drawing Called on an element in a graph after all of its inputs have been processed and before its outputs are processed.
onBeforeOutputsHandled(_id: string, _iModel: IModelDb): void Protected Static Inherited Drawing Called when a root element in a subgraph is changed and before its outputs are processed.
onChildAdd(_arg: OnChildElementPropsArg): void Protected Static Inherited Drawing Called when an existing element is about to be updated so that an instance of this class will become its new parent.
onChildAdded(_arg: OnChildElementIdArg): void Protected Static Inherited Drawing Called after an existing element has been updated so that an instance of this class is its new parent.
onChildDelete(_arg: OnChildElementIdArg): void Protected Static Inherited Drawing Called when an element with an instance of this class as its parent is about to be deleted.
onChildDeleted(_arg: OnChildElementIdArg): void Protected Static Inherited Drawing Called after an element with an instance of this class as its parent was successfully deleted.
onChildDrop(_arg: OnChildElementIdArg): void Protected Static Inherited Drawing Called when an element with an instance of this class as its parent is about to be updated change to a different parent.
onChildDropped(_arg: OnChildElementIdArg): void Protected Static Inherited Drawing Called after an element with an instance of this class as its previous parent was updated to have a new parent.
onChildInsert(_arg: OnChildElementPropsArg): void Protected Static Inherited Drawing Called when a new element with an instance of this class as its parent is about to be inserted.
onChildInserted(_arg: OnChildElementIdArg): void Protected Static Inherited Drawing Called after a new element with an instance of this class as its parent was inserted.
onChildUpdate(_arg: OnChildElementPropsArg): void Protected Static Inherited Drawing Called when an element with an instance of this class as its parent is about to be updated.
onChildUpdated(_arg: OnChildElementIdArg): void Protected Static Inherited Drawing Called after an element with an instance of this the class as its parent was updated.
onCloned(_context: IModelElementCloneContext, _sourceProps: ElementProps, _targetProps: ElementProps): void Protected Static Inherited Drawing Called during the iModel transformation process after an Element from the source iModel was cloned for the target iModel.
onDelete(arg: OnElementIdArg): void Protected Static Inherited Drawing Called before an Element is deleted.
onDeleted(_arg: OnElementIdArg): void Protected Static Inherited Drawing Called after an Element was deleted.
onInsert(arg: OnElementPropsArg): void Protected Static Inherited Drawing Called before a new Element is inserted.
onInserted(arg: OnElementIdArg): void Protected Static Inherited Drawing Called after a new Element was inserted.
onSubModelDelete(_arg: OnSubModelIdArg): void Protected Static Inherited Drawing Called when a sub-model of an instance of this class is being deleted.
onSubModelDeleted(_arg: OnSubModelIdArg): void Protected Static Inherited Drawing Called after a sub-model of an instance of this class was deleted.
onSubModelInsert(_arg: OnSubModelPropsArg): void Protected Static Inherited Drawing Called when an instance of this class is being sub-modeled by a new Model.
onSubModelInserted(_arg: OnSubModelIdArg): void Protected Static Inherited Drawing Called after an instance of this class was sub-modeled by a new Model.
onUpdate(arg: OnElementPropsArg): void Protected Static Inherited Drawing Called before an Element is updated.
onUpdated(_arg: OnElementIdArg): void Protected Static Inherited Drawing Called after an Element was updated.

Properties

Name Type Description
className Accessor Static ReadOnly string The name of the BIS class associated with this class.  
displaySpatialView boolean If true, when displaying the section drawing as a DrawingViewState, the spatialView will also be displayed.  
drawingBoundaryClip ClipVector | undefined If the section drawing is placed onto a Sheet via a ViewAttachment, the clip to apply to the sheet graphics when drawn in the context  
drawingModelFullClassName Accessor Protected Static ReadOnly string The name of the DrawingModel class modeled by this element type.  
drawingToSpatialTransform Transform | undefined A transform from the section drawing model's coordinates to spatial coordinates.  
sectionType SectionType The type of section used to generate the drawing.  
sheetToSpatialTransform Transform | undefined If the section drawing is placed onto a Sheet via a ViewAttachment, a transform from the sheet's coordinates to spatial coordinates.  
spatialView RelatedElement The spatial view from which the section was generated.  

Inherited properties

Name Type Inherited from Description
classFullName Accessor Inherited ReadOnly string Drawing Get the full BIS class name of this Entity in the form "schema:class".
classFullName Accessor Static Inherited ReadOnly string Drawing Get the full BIS class name of this Entity in the form "schema:class"
className Accessor Inherited ReadOnly string Drawing The name of the BIS class associated with this class.
code Inherited Code Drawing The Code for this element
federationGuid Inherited string | undefined Drawing A FederationGuid assigned to this element by some other federated database
id Inherited string Drawing The Id of this Entity.
iModel Inherited IModelDb Drawing The IModelDb that contains this Entity
isInstanceOfEntity Readonly Inherited "true" Drawing An immutable property used to discriminate between Entity and EntityProps, used to inform the TypeScript compiler that these two types
jsonProperties Readonly Inherited { T } Drawing Optional json properties of this element.
model Readonly Inherited string Drawing The ModelId of the Model containing this element
parent Inherited RelatedElement | undefined Drawing The parent element, if present, of this element.
requiredReferenceKeys Static Readonly Inherited ReadonlyArray Drawing A required reference is an element that had to be inserted before this element could have been inserted.
schema Static Inherited Drawing The Schema that defines this class.
schemaName Accessor Inherited ReadOnly string Drawing The name of the BIS Schema that defines this class
userLabel Inherited string | undefined Drawing A user-assigned label for this element.

Defined in

Last Updated: 14 November, 2024