SectionDrawingModel Class

A container for persisting section DrawingGraphics.

Extends

Methods

Name Description
constructor(props: GeometricModel2dProps, iModel: IModelDb): SectionDrawingModel Protected    

Inherited methods

Name Inherited from Description
collectReferenceIds(referenceIds: EntityReferenceSet): void Protected Inherited DrawingModel Collect the Ids of this entity's references at this level of the class hierarchy.
delete(): void Inherited DrawingModel Delete this Model from the iModel.
forEachProperty(func: PropertyCallback, includeCustom: booleantrue): void Inherited DrawingModel Call a function for each property of this Entity.
getJsonProperty(name: string): any Inherited DrawingModel  
getReferenceIds(): EntityReferenceSet Inherited DrawingModel Get the set of this entity's entity references, EntityReferenceSet.
getUserProperties(namespace: string): any Inherited DrawingModel Get a set of JSON user properties by namespace
insert(): string Inherited DrawingModel Insert this Model in the iModel
queryExtents(): Range3d Inherited DrawingModel Query for the union of the extents of the elements contained by this model.
queryRange(): Promise<Range3d> Inherited DrawingModel Query for the union of the extents of all elements contained within this model.
removeUserProperties(nameSpace: string): void Inherited DrawingModel Remove a set of JSON user properties, specified by namespace, from this Element
setJsonProperty(name: string, value: any): void Inherited DrawingModel  
setUserProperties(nameSpace: string, value: any): void Inherited DrawingModel Change a set of user JSON properties of this Element by namespace.
toJSON(): GeometricModel2dProps Inherited DrawingModel Obtain the JSON representation of this Entity.
update(): void Inherited DrawingModel Update this Model in the iModel.
is(otherClass: ): boolean Static Inherited DrawingModel return whether this Entity class is a subclass of another Entity class
onDelete(arg: OnModelIdArg): void Protected Static Inherited DrawingModel Called before a Model is deleted.
onDeleted(_arg: OnModelIdArg): void Protected Static Inherited DrawingModel Called after a Model was deleted.
onDeletedElement(_arg: OnElementInModelIdArg): void Protected Static Inherited DrawingModel Called after an Element in an instance of a Model of this class has been deleted.
onDeleteElement(_arg: OnElementInModelIdArg): void Protected Static Inherited DrawingModel Called when an Element in an instance of a Model of this class is about to be deleted.
onInsert(arg: OnModelPropsArg): void Protected Static Inherited DrawingModel Called before a new Model is inserted.
onInserted(_arg: OnModelIdArg): void Protected Static Inherited DrawingModel Called after a new Model is inserted.
onInsertedElement(_arg: OnElementInModelIdArg): void Protected Static Inherited DrawingModel Called after an Element has been inserted into an instance of a Model of this class.
onInsertElement(_arg: OnElementInModelPropsArg): void Protected Static Inherited DrawingModel Called before a prospective Element is to be inserted into an instance of a Model of this class.
onUpdate(arg: OnModelPropsArg): void Protected Static Inherited DrawingModel Called before a Model is updated.
onUpdated(_arg: OnModelIdArg): void Protected Static Inherited DrawingModel Called after a Model is updated.
onUpdatedElement(_arg: OnElementInModelIdArg): void Protected Static Inherited DrawingModel Called after an Element in an instance of a Model of this class has been updated.
onUpdateElement(_arg: OnElementInModelPropsArg): void Protected Static Inherited DrawingModel Called when an Element in an instance of a Model of this class is about to be updated.

Properties

Name Type Description
className Accessor Static ReadOnly string The name of the BIS class associated with this class.  

Inherited properties

Name Type Inherited from Description
classFullName Accessor Inherited ReadOnly string DrawingModel Get the full BIS class name of this Entity in the form "schema:class".
classFullName Accessor Static Inherited ReadOnly string DrawingModel Get the full BIS class name of this Entity in the form "schema:class"
className Accessor Inherited ReadOnly string DrawingModel The name of the BIS class associated with this class.
geometryGuid Inherited string | undefined DrawingModel  
globalOrigin Inherited Point2d | undefined DrawingModel The actual coordinates of (0,0) in modeling coordinates.
id Inherited string DrawingModel The Id of this Entity.
iModel Inherited IModelDb DrawingModel The IModelDb that contains this Entity
isInstanceOfEntity Readonly Inherited "true" DrawingModel An immutable property used to discriminate between Entity and EntityProps, used to inform the TypeScript compiler that these two types
isPrivate Inherited boolean DrawingModel  
isTemplate Inherited boolean DrawingModel  
jsonProperties Readonly Inherited { T } DrawingModel  
modeledElement Readonly Inherited RelatedElement DrawingModel  
name Readonly Inherited string DrawingModel  
parentModel Readonly Inherited string DrawingModel  
schema Static Inherited DrawingModel The Schema that defines this class.
schemaName Accessor Inherited ReadOnly string DrawingModel The name of the BIS Schema that defines this class

Defined in

Last Updated: 14 November, 2024