DrawingModel Class

A 2d model that holds DrawingGraphics. DrawingModels may be dimensional or non-dimensional.

Extends

Extended by

Methods

Name Description
constructor(props: GeometricModel2dProps, iModel: IModelDb): DrawingModel Protected    

Inherited methods

Name Inherited from Description
collectReferenceIds(referenceIds: EntityReferenceSet): void Protected Inherited GraphicalModel2d Collect the Ids of this entity's references at this level of the class hierarchy.
delete(): void Inherited GraphicalModel2d Delete this Model from the iModel.
forEachProperty(func: PropertyCallback, includeCustom: booleantrue): void Inherited GraphicalModel2d Call a function for each property of this Entity.
getJsonProperty(name: string): any Inherited GraphicalModel2d  
getReferenceIds(): EntityReferenceSet Inherited GraphicalModel2d Get the set of this entity's entity references, EntityReferenceSet.
getUserProperties(namespace: string): any Inherited GraphicalModel2d Get a set of JSON user properties by namespace
insert(): string Inherited GraphicalModel2d Insert this Model in the iModel
queryExtents(): Range3d Inherited GraphicalModel2d Query for the union of the extents of the elements contained by this model.
queryRange(): Promise<Range3d> Inherited GraphicalModel2d Query for the union of the extents of all elements contained within this model.
removeUserProperties(nameSpace: string): void Inherited GraphicalModel2d Remove a set of JSON user properties, specified by namespace, from this Element
setJsonProperty(name: string, value: any): void Inherited GraphicalModel2d  
setUserProperties(nameSpace: string, value: any): void Inherited GraphicalModel2d Change a set of user JSON properties of this Element by namespace.
toJSON(): GeometricModel2dProps Inherited GraphicalModel2d Obtain the JSON representation of this Entity.
update(): void Inherited GraphicalModel2d Update this Model in the iModel.
is(otherClass: ): boolean Static Inherited GraphicalModel2d return whether this Entity class is a subclass of another Entity class
onDelete(arg: OnModelIdArg): void Protected Static Inherited GraphicalModel2d Called before a Model is deleted.
onDeleted(_arg: OnModelIdArg): void Protected Static Inherited GraphicalModel2d Called after a Model was deleted.
onDeletedElement(_arg: OnElementInModelIdArg): void Protected Static Inherited GraphicalModel2d Called after an Element in an instance of a Model of this class has been deleted.
onDeleteElement(_arg: OnElementInModelIdArg): void Protected Static Inherited GraphicalModel2d Called when an Element in an instance of a Model of this class is about to be deleted.
onInsert(arg: OnModelPropsArg): void Protected Static Inherited GraphicalModel2d Called before a new Model is inserted.
onInserted(_arg: OnModelIdArg): void Protected Static Inherited GraphicalModel2d Called after a new Model is inserted.
onInsertedElement(_arg: OnElementInModelIdArg): void Protected Static Inherited GraphicalModel2d Called after an Element has been inserted into an instance of a Model of this class.
onInsertElement(_arg: OnElementInModelPropsArg): void Protected Static Inherited GraphicalModel2d Called before a prospective Element is to be inserted into an instance of a Model of this class.
onUpdate(arg: OnModelPropsArg): void Protected Static Inherited GraphicalModel2d Called before a Model is updated.
onUpdated(_arg: OnModelIdArg): void Protected Static Inherited GraphicalModel2d Called after a Model is updated.
onUpdatedElement(_arg: OnElementInModelIdArg): void Protected Static Inherited GraphicalModel2d Called after an Element in an instance of a Model of this class has been updated.
onUpdateElement(_arg: OnElementInModelPropsArg): void Protected Static Inherited GraphicalModel2d Called when an Element in an instance of a Model of this class is about to be updated.

Properties

Name Type Description
className Accessor Static ReadOnly string The name of the BIS class associated with this class.  

Inherited properties

Name Type Inherited from Description
classFullName Accessor Inherited ReadOnly string GraphicalModel2d Get the full BIS class name of this Entity in the form "schema:class".
classFullName Accessor Static Inherited ReadOnly string GraphicalModel2d Get the full BIS class name of this Entity in the form "schema:class"
className Accessor Inherited ReadOnly string GraphicalModel2d The name of the BIS class associated with this class.
geometryGuid Inherited string | undefined GraphicalModel2d  
globalOrigin Inherited Point2d | undefined GraphicalModel2d The actual coordinates of (0,0) in modeling coordinates.
id Inherited string GraphicalModel2d The Id of this Entity.
iModel Inherited IModelDb GraphicalModel2d The IModelDb that contains this Entity
isInstanceOfEntity Readonly Inherited "true" GraphicalModel2d An immutable property used to discriminate between Entity and EntityProps, used to inform the TypeScript compiler that these two types
isPrivate Inherited boolean GraphicalModel2d  
isTemplate Inherited boolean GraphicalModel2d  
jsonProperties Readonly Inherited { T } GraphicalModel2d  
modeledElement Readonly Inherited RelatedElement GraphicalModel2d  
name Readonly Inherited string GraphicalModel2d  
parentModel Readonly Inherited string GraphicalModel2d  
schema Static Inherited GraphicalModel2d The Schema that defines this class.
schemaName Accessor Inherited ReadOnly string GraphicalModel2d The name of the BIS Schema that defines this class

Defined in

Last Updated: 14 November, 2024