OnElementInModelPropsArg Interface
Argument for the Model.onXxxElement
static methods that supply the properties of an Element for a Model.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
elementProps | Readonly<ElementProps> | The new properties of an Element for the affected Model |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
iModel | IModelDb | OnModelIdArg | The iModel for the Model affected. |
id | string | OnModelIdArg | The Id of the Model affected |
Defined in
- core/backend/src/Model.ts Line 50
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.