GeometricModel2dProps Interface
Properties that define a GeometricModel2d
Extends
Properties
Name | Type | Description | |
---|---|---|---|
globalOrigin | XYProps | undefined | The actual coordinates of (0,0) in modeling coordinates. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
classFullName | string | GeometricModelProps | The full name of the ECClass for this entity, in the form "Schema:ClassName" |
geometryGuid | string | undefined | GeometricModelProps | A unique identifier that is updated each time a change affecting the appearance of a geometric element within this model |
id | string | undefined | GeometricModelProps | The Id of the entity. |
isInstanceOfEntity Readonly | undefined | undefined | GeometricModelProps | A non-existent property used to discriminate between EntityProps and Entity. |
isPrivate | boolean | undefined | GeometricModelProps | |
isTemplate | boolean | undefined | GeometricModelProps | |
jsonProperties | any | undefined | GeometricModelProps | Optional json properties of this Entity. |
modeledElement | RelatedElementProps | GeometricModelProps | |
name | string | undefined | GeometricModelProps | |
parentModel | string | undefined | GeometricModelProps |
Defined in
- core/common/src/ModelProps.ts Line 64
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.