GeometricModelProps Interface
Properties that describe a GeometricModel
Extends
Properties
Name | Type | Description | |
---|---|---|---|
geometryGuid | string | undefined | A unique identifier that is updated each time a change affecting the appearance of a geometric element within this model |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
classFullName | string | ModelProps | The full name of the ECClass for this entity, in the form "Schema:ClassName" |
id | string | undefined | ModelProps | The Id of the entity. |
isInstanceOfEntity Readonly | undefined | undefined | ModelProps | A non-existent property used to discriminate between EntityProps and Entity. |
isPrivate | boolean | undefined | ModelProps | |
isTemplate | boolean | undefined | ModelProps | |
jsonProperties | any | undefined | ModelProps | Optional json properties of this Entity. |
modeledElement | RelatedElementProps | ModelProps | |
name | string | undefined | ModelProps | |
parentModel | string | undefined | ModelProps |
Defined in
- core/common/src/ModelProps.ts Line 51
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.