ModelProps Interface
Properties that define a Model
Extends
Properties
Name | Type | Description | |
---|---|---|---|
isPrivate | boolean | undefined | ||
isTemplate | boolean | undefined | ||
jsonProperties | any | undefined | Optional json properties of this Entity. | |
modeledElement | RelatedElementProps | ||
name | string | undefined | ||
parentModel | string | undefined |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
classFullName | string | EntityProps | The full name of the ECClass for this entity, in the form "Schema:ClassName" |
id | string | undefined | EntityProps | The Id of the entity. |
isInstanceOfEntity Readonly | undefined | undefined | EntityProps | A non-existent property used to discriminate between EntityProps and Entity. |
Defined in
- core/common/src/ModelProps.ts Line 19
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.