GraphicalModel3d Class
A container for persisting GraphicalElement3d instances.
@note The associated ECClass was added to the BisCore schema in version 1.0.8
@see GraphicalPartition3d
Extends
Extended by
Methods
Name | Description | |
---|---|---|
constructor(props: GeometricModel3dProps, iModel: IModelDb): GraphicalModel3d Protected |
Inherited methods
Name | Inherited from | Description |
---|---|---|
collectReferenceIds(referenceIds: EntityReferenceSet): void Protected | GeometricModel3d | Collect the Ids of this entity's references at this level of the class hierarchy. |
delete(): void | GeometricModel3d | Delete this Model from the iModel. |
forEachProperty(func: PropertyCallback, includeCustom: booleantrue): void | GeometricModel3d | Call a function for each property of this Entity. |
getJsonProperty(name: string): any | GeometricModel3d | |
getReferenceIds(): EntityReferenceSet | GeometricModel3d | Get the set of this entity's entity references, EntityReferenceSet. |
getUserProperties(namespace: string): any | GeometricModel3d | Get a set of JSON user properties by namespace |
insert(): string | GeometricModel3d | Insert this Model in the iModel |
queryExtents(): Range3d | GeometricModel3d | Query for the union of the extents of the elements contained by this model. |
queryRange(): Promise<Range3d> | GeometricModel3d | Query for the union of the extents of all elements contained within this model. |
removeUserProperties(nameSpace: string): void | GeometricModel3d | Remove a set of JSON user properties, specified by namespace, from this Element |
setJsonProperty(name: string, value: any): void | GeometricModel3d | |
setUserProperties(nameSpace: string, value: any): void | GeometricModel3d | Change a set of user JSON properties of this Element by namespace. |
toJSON(): GeometricModel3dProps | GeometricModel3d | Obtain the JSON representation of this Entity. |
update(): void | GeometricModel3d | Update this Model in the iModel. |
is(otherClass: ): boolean Static | GeometricModel3d | return whether this Entity class is a subclass of another Entity class |
onDelete(arg: OnModelIdArg): void Protected Static | GeometricModel3d | Called before a Model is deleted. |
onDeleteElement(_arg: OnElementInModelIdArg): void Protected Static | GeometricModel3d | Called when an Element in an instance of a Model of this class is about to be deleted. |
onDeleted(_arg: OnModelIdArg): void Protected Static | GeometricModel3d | Called after a Model was deleted. |
onDeletedElement(_arg: OnElementInModelIdArg): void Protected Static | GeometricModel3d | Called after an Element in an instance of a Model of this class has been deleted. |
onInsert(arg: OnModelPropsArg): void Protected Static | GeometricModel3d | Called before a new Model is inserted. |
onInsertElement(_arg: OnElementInModelPropsArg): void Protected Static | GeometricModel3d | Called before a prospective Element is to be inserted into an instance of a Model of this class. |
onInserted(_arg: OnModelIdArg): void Protected Static | GeometricModel3d | Called after a new Model is inserted. |
onInsertedElement(_arg: OnElementInModelIdArg): void Protected Static | GeometricModel3d | Called after an Element has been inserted into an instance of a Model of this class. |
onUpdate(arg: OnModelPropsArg): void Protected Static | GeometricModel3d | Called before a Model is updated. |
onUpdateElement(_arg: OnElementInModelPropsArg): void Protected Static | GeometricModel3d | Called when an Element in an instance of a Model of this class is about to be updated. |
onUpdated(_arg: OnModelIdArg): void Protected Static | GeometricModel3d | Called after a Model is updated. |
onUpdatedElement(_arg: OnElementInModelIdArg): void Protected Static | GeometricModel3d | Called after an Element in an instance of a Model of this class has been updated. |
Properties
Name | Type | Description | |
---|---|---|---|
className Accessor Static ReadOnly | string | The name of the BIS class associated with this class. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
classFullName Accessor ReadOnly | string | GeometricModel3d | Get the full BIS class name of this Entity in the form "schema:class". |
classFullName Accessor Static ReadOnly | string | GeometricModel3d | Get the full BIS class name of this Entity in the form "schema:class" |
className Accessor ReadOnly | string | GeometricModel3d | The name of the BIS class associated with this class. |
geometryGuid | string | undefined | GeometricModel3d | |
id | string | GeometricModel3d | The Id of this Entity. |
iModel | IModelDb | GeometricModel3d | The IModelDb that contains this Entity |
isInstanceOfEntity Readonly | "true" | GeometricModel3d | An immutable property used to discriminate between Entity and EntityProps, used to inform the TypeScript compiler that these two types |
isNotSpatiallyLocated Readonly | boolean | GeometricModel3d | If true, then the elements in this GeometricModel3d are not in real-world coordinates and will not be in the spatial index. |
isPlanProjection Readonly | boolean | GeometricModel3d | If true, then the elements in this GeometricModel3d are expected to be in an XY plane. |
isPrivate | boolean | GeometricModel3d | |
isSpatiallyLocated Accessor ReadOnly | boolean | GeometricModel3d | If true, then the elements in this GeometricModel3d are in real-world coordinates and will be in the spatial index. |
isTemplate | boolean | GeometricModel3d | |
jsonProperties Readonly | [key: string]: any | GeometricModel3d | |
modeledElement Readonly | RelatedElement | GeometricModel3d | |
name Readonly | string | GeometricModel3d | |
parentModel Readonly | string | GeometricModel3d | |
schema Static | GeometricModel3d | The Schema that defines this class. | |
schemaName Accessor ReadOnly | string | GeometricModel3d | The name of the BIS Schema that defines this class |
Defined in
- core/backend/src/Model.ts Line 322
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.