EntityMetaData Class
Metadata for an Entity.
Implements
Methods
Name | Description | |
---|---|---|
constructor(jsonObj: EntityMetaDataProps): EntityMetaData |
Properties
Name | Type | Description | |
---|---|---|---|
baseClasses Readonly | string[] | The base class that this class is derives from. | |
classId Readonly | string | The Id of the class in the IModelDb from which the metadata was obtained. | |
customAttributes Readonly | CustomAttribute[] | undefined | The Custom Attributes for this class | |
description Readonly | string | undefined | ||
displayLabel Readonly | string | undefined | ||
ecclass Readonly | string | The Entity name | |
modifier Readonly | string | undefined | ||
properties Readonly | { T } | An object whose properties correspond by name to the properties of this class. |
Defined in
- core/common/src/EntityProps.ts Line 238
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.