PropertyMetaData Class
Metadata for a property.
Implements
Methods
Name | Description | |
---|---|---|
constructor(jsonObj: PropertyMetaDataProps): PropertyMetaData | ||
createProperty(jsonObj: any): any | construct a single property from an input object according to this metadata |
Properties
Name | Type | Description | |
---|---|---|---|
customAttributes | CustomAttribute[] | undefined | ||
description | string | undefined | ||
direction | string | undefined | ||
displayLabel | string | undefined | ||
extendedType | string | undefined | ||
isCustomHandled | boolean | undefined | ||
isCustomHandledOrphan | boolean | undefined | ||
isNavigation Accessor ReadOnly | boolean | Return true if this property is a NavigationProperty. |
|
kindOfQuantity | string | undefined | ||
maximumLength | number | undefined | ||
maximumValue | any | undefined | ||
maxOccurs | number | undefined | ||
minimumLength | number | undefined | ||
minimumValue | any | undefined | ||
minOccurs | number | undefined | ||
primitiveType | PrimitiveTypeCode | undefined | ||
readOnly | boolean | undefined | ||
relationshipClass | string | undefined | ||
structName | string | undefined |
Defined in
- core/common/src/EntityProps.ts Line 131
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.