RenderTimeline Class
Describes how to animate a view of a GeometricModel to show change over time using a RenderSchedule.Script.
@note This class was introduced in version 01.00.13 of the BisCore ECSchema. It should only be used with IModelDbs containing that version or newer.
Extends
Methods
Name | Description | |
---|---|---|
constructor(props: RenderTimelineProps, iModel: IModelDb): RenderTimeline Protected | ||
collectReferenceIds(ids: EntityReferenceSet): void Protected | Collect the Ids of this entity's references at this level of the class hierarchy. | |
toJSON(): RenderTimelineProps | Obtain the JSON representation of this Entity. | |
fromJSON(props: RenderTimelineProps, iModel: IModelDb): RenderTimeline Static | ||
remapScript(context: IModelElementCloneContext, input: RenderSchedule.ScriptProps): RenderSchedule.ScriptProps Static | Remap Ids when cloning a RenderSchedule.Script between iModels on a DisplayStyle or RenderTimeline. |
Inherited methods
Name | Inherited from | Description |
---|---|---|
collectPredecessorIds(predecessorIds: EntityReferenceSet): void Protected | InformationRecordElement | Collect the Ids of this element's references at this level of the class hierarchy. |
delete(): void | InformationRecordElement | Delete this Element from the iModel. |
forEachProperty(func: PropertyCallback, includeCustom: booleantrue): void | InformationRecordElement | Call a function for each property of this Entity. |
getClassMetaData(): undefined | EntityMetaData | InformationRecordElement | Get the class metadata for this element. |
getDisplayLabel(): string | InformationRecordElement | Get a display label for this Element. |
getJsonProperty(nameSpace: string): any | InformationRecordElement | Get a JSON property of this element, by namespace |
getPredecessorIds(): Id64Set | InformationRecordElement | Get the Ids of this element's references. |
getReferenceIds(): EntityReferenceSet | InformationRecordElement | Get the set of this entity's entity references, EntityReferenceSet. |
InformationRecordElement | Get a list of HTML strings that describe this Element for the tooltip. | |
getUserProperties(namespace: string): any | InformationRecordElement | Get a set of JSON user properties by namespace |
insert(): string | InformationRecordElement | Insert this Element into the iModel. |
removeUserProperties(nameSpace: string): void | InformationRecordElement | Remove a set of JSON user properties, specified by namespace, from this Element |
setJsonProperty(nameSpace: string, value: any): void | InformationRecordElement | |
setUserProperties(nameSpace: string, value: any): void | InformationRecordElement | Change a set of user JSON properties of this Element by namespace. |
update(): void | InformationRecordElement | Update this Element in the iModel. |
is(otherClass: ): boolean Static | InformationRecordElement | return whether this Entity class is a subclass of another Entity class |
onAllInputsHandled(_id: string, _iModel: IModelDb): void Protected Static | InformationRecordElement | Called on an element in a graph after all of its inputs have been processed and before its outputs are processed. |
onBeforeOutputsHandled(_id: string, _iModel: IModelDb): void Protected Static | InformationRecordElement | Called when a root element in a subgraph is changed and before its outputs are processed. |
onChildAdd(_arg: OnChildElementPropsArg): void Protected Static | InformationRecordElement | Called when an existing element is about to be updated so that an instance of this class will become its new parent. |
onChildAdded(_arg: OnChildElementIdArg): void Protected Static | InformationRecordElement | Called after an existing element has been updated so that an instance of this class is its new parent. |
onChildDelete(_arg: OnChildElementIdArg): void Protected Static | InformationRecordElement | Called when an element with an instance of this class as its parent is about to be deleted. |
onChildDeleted(_arg: OnChildElementIdArg): void Protected Static | InformationRecordElement | Called after an element with an instance of this class as its parent was successfully deleted. |
onChildDrop(_arg: OnChildElementIdArg): void Protected Static | InformationRecordElement | Called when an element with an instance of this class as its parent is about to be updated change to a different parent. |
onChildDropped(_arg: OnChildElementIdArg): void Protected Static | InformationRecordElement | Called after an element with an instance of this class as its previous parent was updated to have a new parent. |
onChildInsert(_arg: OnChildElementPropsArg): void Protected Static | InformationRecordElement | Called when a new element with an instance of this class as its parent is about to be inserted. |
onChildInserted(_arg: OnChildElementIdArg): void Protected Static | InformationRecordElement | Called after a new element with an instance of this class as its parent was inserted. |
onChildUpdate(_arg: OnChildElementPropsArg): void Protected Static | InformationRecordElement | Called when an element with an instance of this class as its parent is about to be updated. |
onChildUpdated(_arg: OnChildElementIdArg): void Protected Static | InformationRecordElement | Called after an element with an instance of this the class as its parent was updated. |
onDelete(arg: OnElementIdArg): void Protected Static | InformationRecordElement | Called before an Element is deleted. |
onDeleted(_arg: OnElementIdArg): void Protected Static | InformationRecordElement | Called after an Element was deleted. |
onInsert(arg: OnElementPropsArg): void Protected Static | InformationRecordElement | Called before a new Element is inserted. |
onInserted(arg: OnElementIdArg): void Protected Static | InformationRecordElement | Called after a new Element was inserted. |
onSubModelDelete(_arg: OnSubModelIdArg): void Protected Static | InformationRecordElement | Called when a sub-model of an instance of this class is being deleted. |
onSubModelDeleted(_arg: OnSubModelIdArg): void Protected Static | InformationRecordElement | Called after a sub-model of an instance of this class was deleted. |
onSubModelInsert(_arg: OnSubModelPropsArg): void Protected Static | InformationRecordElement | Called when an instance of this class is being sub-modeled by a new Model. |
onSubModelInserted(_arg: OnSubModelIdArg): void Protected Static | InformationRecordElement | Called after an instance of this class was sub-modeled by a new Model. |
onUpdate(arg: OnElementPropsArg): void Protected Static | InformationRecordElement | Called before an Element is updated. |
onUpdated(_arg: OnElementIdArg): void Protected Static | InformationRecordElement | Called after an Element was updated. |
Properties
Name | Type | Description | |
---|---|---|---|
className Accessor Static ReadOnly | string | The name of the BIS class associated with this class. | |
description | string | A human-readable description of the timeline, which may be an empty string. | |
scriptProps | RenderSchedule.ScriptProps | The JSON representation of the instructions for visualizing change over time. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
classFullName Accessor ReadOnly | string | InformationRecordElement | Get the full BIS class name of this Entity in the form "schema:class". |
classFullName Accessor Static ReadOnly | string | InformationRecordElement | Get the full BIS class name of this Entity in the form "schema:class" |
className Accessor ReadOnly | string | InformationRecordElement | The name of the BIS class associated with this class. |
code | Code | InformationRecordElement | The Code for this element |
federationGuid | string | undefined | InformationRecordElement | A FederationGuid assigned to this element by some other federated database |
id | string | InformationRecordElement | The Id of this Entity. |
iModel | IModelDb | InformationRecordElement | The IModelDb that contains this Entity |
isInstanceOfEntity Readonly | "true" | InformationRecordElement | An immutable property used to discriminate between Entity and EntityProps, used to inform the TypeScript compiler that these two types |
jsonProperties Readonly | [key: string]: any | InformationRecordElement | Optional json properties of this element. |
model Readonly | string | InformationRecordElement | The ModelId of the Model containing this element |
parent | RelatedElement | undefined | InformationRecordElement | The parent element, if present, of this element. |
requiredReferenceKeys Static Readonly | ReadonlyArray |
InformationRecordElement | A required reference is an element that had to be inserted before this element could have been inserted. |
schema Static | InformationRecordElement | The Schema that defines this class. | |
schemaName Accessor ReadOnly | string | InformationRecordElement | The name of the BIS Schema that defines this class |
userLabel | string | undefined | InformationRecordElement | A user-assigned label for this element. |
Defined in
- core/backend/src/Element.ts Line 1497
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.