Synchronizer Class
Helper class for interacting with the iModelDb during synchronization.
Methods
Name | Description | |
---|---|---|
constructor(imodel: IModelDb, _supportsMultipleFilesPerChannel: boolean, _requestContext?: string, _scopeToPartition?: boolean, _channelKey?: string, _authMgr?: ConnectorAuthenticationManager): Synchronizer | ||
deleteSynchronizationConfigLinkIfUnmappingLastExternalSource(repLinkIdToUnmap: string): Promise<void> | ||
detectChanges(item: SourceItem): ChangeResults | Detect if the item has changed or is new. | |
detectDeletedElements(): void | Deletes elements from a BriefcaseDb that were previously converted but not longer exist in the source data. | |
detectDeletedElementsInChannel(): void | Detect and delete all elements and models that meet the following conditions: | |
ensureRootSourceRelationshipExists(config: string, docId: string): void | Creates a relationship between the SynchConfigLink and the ExternalSource if one doesn't exist already. | |
get(): undefined | ConnectorAuthenticationManager | ||
getExternalSourceCount(): number | ||
getExternalSourceElement(repositoryLink: Element): undefined | ExternalSourceProps | Returns the External Source Element associated with a repository link | |
getExternalSourceElementByLinkId(repositoryLinkId: string): undefined | ExternalSourceProps | Returns the External Source Element associated with a repository link | |
insertResultsIntoIModel(results: SynchronizationResults, aspectProps: ExternalSourceAspectProps): IModelStatus | Given synchronizations results for an element (and possibly its children), insert the new element into the bim | |
makeExternalSourceAspectProps(sourceItem: SourceItem): ExternalSourceAspectProps | ||
onElementSeen(id: string): void | Records that this particular element was visited during this synchronization. | |
recordDocument(sourceDocument: SourceDocument): RecordDocumentResults | Insert or update a RepositoryLink element to represent the source document. | |
set(authMgr: ConnectorAuthenticationManager): void | ||
setExternalSourceAspect(element: ElementProps, itemState: ItemState, sourceItem: SourceItem): IModelStatus | Adds or updates the external source aspect for the given source item onto the related element - this function is rarely needed, | |
updateIModel(results: SynchronizationResults, sourceItem: SourceItem): IModelStatus | Update the iModel with the results of converting an item to one or more Elements. | |
updateRepositoryLinks(): void | ||
updateResultsInIModel(results: SynchronizationResults, aspectProps: ExternalSourceAspectProps): IModelStatus | Given synchronizations results for an element (and possibly its children), updates element in the bim | |
parseDocGuidFromPwUri(pwUri: string): string Static | Utility function to parse the GUID portion of a ProjectWise URI. |
Properties
Name | Type | Description | |
---|---|---|---|
_requestContext Protected | string | undefined | ||
authenticationManager | ConnectorAuthenticationManager | undefined | ||
imodel Readonly | IModelDb | ||
jobSubjectId Accessor | string | ||
linkCount Accessor ReadOnly | number | ||
unchangedSources Accessor ReadOnly | string[] |
Defined in
- Synchronizer.ts Line 212
Last Updated: 06 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.