CallbackUrlClient Class

A special implementation of a CachedTokenClient whose constructor takes a single callback URL. This will cache the token locally until it has expired based on the expiration time in the URL response.

Extends

  • CachedTokenClient

Extended by

Methods

Name Description
constructor(callbackUrl: string): CallbackUrlClient    
fetch(): Promise<Response> Protected    
getAccessToken(): Promise<string>    

Inherited methods

Name Inherited from Description
getCachedTokenIfNotExpired(freshTokenGetter: AccessTokenWExpirationGetter): Promise<string> Protected CachedTokenClient Returns either a freshToken if there is no cached token or if currently cached token has expired, otherwise it will return a fresh token

Defined in

Last Updated: 13 September, 2024