Fetcher Class

Fetcher

Methods

Name Description
constructor(params: FetcherParams): Fetcher    
execute(): Promise<any>    

Properties

Name Type Description
_callback Protected fetcherCallback | undefined The callback used to process the response  
_hostName Protected string The host name  
_method Protected "POST" | "GET" | "PATCH" The method  
_modelId Protected string The model id  
_token Protected string The auth token  
_urlFolderPath Protected string The url folder path  
headers Accessor Protected ReadOnly { Accept: string, Authorization: string, Content-type: string }    
url Accessor Protected ReadOnly string    

Defined in

Last Updated: 06 September, 2024