BriefcaseConnection Class
A connection to an editable briefcase on the backend. This class uses Ipc to communicate to the backend and may only be used by IpcApps.
Extends
Methods
Name | Description | |
---|---|---|
constructor(props: IModelConnectionProps, openMode: OpenMode): BriefcaseConnection Protected | ||
close(): Promise<void> | Close this BriefcaseConnection. | |
enterEditingScope(): Promise<GraphicalEditingScope> | Begin a new graphical editing scope. | |
hasPendingTxns(): Promise<boolean> | Query if there are any pending Txns in this briefcase that are waiting to be pushed. | |
pullChanges(toIndex?: number, options?: PullChangesOptions): Promise<void> | Pull (and potentially merge if there are local changes) up to a specified changeset from iModelHub into this briefcase | |
pushChanges(description: string): Promise<ChangesetIndexAndId> | Create a changeset from local Txns and push to iModelHub. | |
saveChanges(description?: string): Promise<void> | Commit pending changes to this briefcase. | |
supportsGraphicalEditing(): Promise<boolean> | Return whether graphical editing is supported for this briefcase. | |
openFile(briefcaseProps: OpenBriefcaseProps): Promise<BriefcaseConnection> Static | Open a BriefcaseConnection to a BriefcaseDb. | |
openStandalone(filePath: string, openMode: OpenModeOpenMode.ReadWrite, opts?: OpenDbKey): Promise<BriefcaseConnection> Static | Open a BriefcaseConnection to a StandaloneDb |
Inherited methods
Name | Inherited from | Description |
---|---|---|
cartographicFromSpatial(spatial: Readonly<WritableXYAndZ>[]): Promise<Cartographic[]> | IModelConnection | Convert points in this iModel's spatial coordinate system to Cartographic coordinates using either a GeoConverter or the iModel's EcefLocation. |
cartographicToSpatial(cartographic: Cartographic, result?: Point3d): Promise<Point3d> | IModelConnection | Convert a Cartographic to a point in this iModel's Spatial coordinates using a GeoConverter or[IModel.ecefLocation. |
cartographicToSpatialFromEcef(cartographic: Cartographic, result?: Point3d): Point3d | IModelConnection | Convert a Cartographic to a point in this iModel's Spatial coordinates using its IModel.ecefLocation. |
cartographicToSpatialFromGcs(cartographic: Cartographic, result?: Point3d): Promise<Point3d> | IModelConnection | Convert a Cartographic to a point in this iModel's spatial coordinate system using a GeoConverter. |
createQueryReader(ecsql: string, params?: QueryBinder, config?: QueryOptions): ECSqlReader | IModelConnection | Allow to execute query and read results along with meta data. |
ecefToSpatial(ecef: Readonly<WritableXYAndZ>, result?: Point3d): Point3d | IModelConnection | Convert a point in ECEF coordinates to a point in this iModel's Spatial coordinates using its ecefLocation. |
expandDisplayedExtents(range: Range3d): void | IModelConnection | Expand this iModel's displayedExtents to include the specified range. |
findClassFor<T extends >(className: string, defaultClass: T): Promise<undefined | T> | IModelConnection | Find the first registered base class of the given EntityState className. |
generateElementMeshes(requestProps: ElementMeshRequestProps): Promise<Uint8Array> | IModelConnection | Produce encoded Polyfaces from the geometry stream of a GeometricElement. |
getEcefTransform(): Transform | IModelConnection | Get the Transform from this iModel's Spatial coordinates to ECEF coordinates using its IModel.ecefLocation. |
getGeometryContainment(requestProps: GeometryContainmentRequestProps): Promise<GeometryContainmentResponseProps> | IModelConnection | Request element clip containment status from the backend. |
getGeometrySummary(requestProps: GeometrySummaryRequestProps): Promise<string> | IModelConnection | Obtain a summary of the geometry belonging to one or more GeometricElements suitable for debugging and diagnostics. |
getMassProperties(requestProps: MassPropertiesRequestProps): Promise<MassPropertiesResponseProps> | IModelConnection | Request element mass properties from the backend. |
getMassPropertiesPerCandidate(requestProps: MassPropertiesPerCandidateRequestProps): Promise<MassPropertiesPerCandidateResponseProps[]> | IModelConnection | Request mass properties for multiple elements from the backend. |
getRpcProps(): IModelRpcProps | IModelConnection | Return a token for RPC operations. |
IModelConnection | Request a tooltip from the backend. | |
isBlankConnection(): this is BlankConnection | IModelConnection | Type guard for instanceof BlankConnection |
isCheckpointConnection(): this is CheckpointConnection | IModelConnection | Type guard for instanceof CheckpointConnection |
isSnapshotConnection(): this is SnapshotConnection | IModelConnection | Type guard for instanceof SnapshotConnection |
loadFontMap(): Promise<FontMap> | IModelConnection | Load the FontMap for this IModelConnection. |
query(ecsql: string, params?: QueryBinder, options?: QueryOptions): AsyncIterableIterator<any> | IModelConnection | Execute a query and stream its results |
queryEntityIds(params: EntityQueryParams): Promise<Id64Set> | IModelConnection | Query for a set of element ids that satisfy the supplied query params |
queryRowCount(ecsql: string, params?: QueryBinder): Promise<number> | IModelConnection | Compute number of rows that would be returned by the ECSQL. |
queryTextureData(textureLoadProps: TextureLoadProps): Promise<undefined | TextureData> | IModelConnection | Request a named texture image from the backend. |
restartQuery(token: string, ecsql: string, params?: QueryBinder, options?: QueryOptions): AsyncIterableIterator<any> | IModelConnection | Cancel any previous query with same token and run execute the current specified query. |
setEcefLocation(ecef: EcefLocationProps): void | IModelConnection | Set the EcefLocation for this iModel. |
setGeographicCoordinateSystem(geoCRS: GeographicCRSProps): void | IModelConnection | Sets the geographic coordinate reference system from GeographicCRSProps. |
spatialFromCartographic(cartographic: Cartographic[]): Promise<Point3d[]> | IModelConnection | Convert Cartographic coordinates into points in this iModel's spatial coordinate system using a GeoConverter or the iModel's EcefLocation. |
spatialToCartographic(spatial: Readonly<WritableXYAndZ>, result?: Cartographic): Promise<Cartographic> | IModelConnection | Convert a point in this iModel's Spatial coordinates to a Cartographic using the Geographic location services for this IModelConnection or IModel.ecefLocation. |
spatialToCartographicFromEcef(spatial: Readonly<WritableXYAndZ>, result?: Cartographic): Cartographic | IModelConnection | Convert a point in this iModel's Spatial coordinates to a Cartographic using its IModel.ecefLocation. |
spatialToCartographicFromGcs(spatial: Readonly<WritableXYAndZ>, result?: Cartographic): Promise<Cartographic> | IModelConnection | Convert a point in this iModel's Spatial coordinates to a Cartographic using the Geographic location services for this IModelConnection. |
spatialToEcef(spatial: Readonly<WritableXYAndZ>, result?: Point3d): Point3d | IModelConnection | Convert a point in this iModel's Spatial coordinates to an ECEF point using its IModel.ecefLocation. |
toJSON(): IModelConnectionProps | IModelConnection | Convert this iModel to a JSON representation. |
toSpatialFromGcs(geoCoords: Readonly<WritableXYAndZ>[], datumOrGCRS?: string | GeographicCRSProps): Promise<Point3d[]> | IModelConnection | Convert geographic coordinates into points in this iModel's spatial coordinate system using a GeoConverter or the iModel's EcefLocation. |
wgs84CartographicFromSpatial(spatial: Readonly<WritableXYAndZ>[]): Promise<Cartographic[]> | IModelConnection | Convert points in this iModel's spatial coordinate system to Cartographic coordinates using either a GeoConverter or the iModel's EcefLocation. |
getDefaultSubCategoryId(categoryId: string): string Static | IModelConnection | Get the default subCategoryId for the supplied categoryId |
Properties
Name | Type | Description | |
---|---|---|---|
_isClosed Protected | boolean | undefined | ||
editingScope Accessor ReadOnly | undefined | GraphicalEditingScope | The current graphical editing scope, if one is in progress. | |
editorToolSettings Readonly | BriefcaseEditorToolSettings | Default settings that can be used to control the behavior of Tools that modify this briefcase. | |
iModelId Accessor ReadOnly | string | The Guid that identifies this iModel. | |
isClosed Accessor ReadOnly | boolean | Returns true if close has already been called. |
|
iTwinId Accessor ReadOnly | string | The Guid that identifies the iTwin that owns this iModel. | |
txns Readonly | BriefcaseTxns | Manages local changes to the briefcase via Txns. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
_openMode Protected | OpenMode | IModelConnection | |
categories Readonly | IModelConnection.Categories | IModelConnection | The set of Category's in this IModelConnection. |
changeset Accessor | ChangesetIdWithIndex | IModelConnection | |
codeSpecs Readonly | IModelConnection.CodeSpecs | IModelConnection | The CodeSpecs in this IModelConnection. |
connectionTimeout Static | number | IModelConnection | The maximum time (in milliseconds) to wait before timing out the request to open a connection to a new iModel |
dictionaryId Static Readonly | string | IModelConnection | The Id of the dictionary model. |
displayedExtents Readonly | Range3d | IModelConnection | The displayed extents of this iModel, initialized to IModel.projectExtents. |
ecefLocation Accessor | undefined | EcefLocation | IModelConnection | The EcefLocation of the iModel in Earth Centered Earth Fixed coordinates. If the iModel property geographicCoordinateSystem is not defined then the ecefLocation provides a geolocation by defining a 3D coordinate system relative to the Earth model WGS84. Refer to additional documentation for details. If the geographicCoordinateSystem property is defined then the ecefLocation must be used with care. When the geographicCoordinateSystem is defined it indicates the iModel cartesian space is the result of a cartographic projection. This implies a flattening of the Earth surface process that results in scale, angular or area distortion. The ecefLocation is then an approximation calculated at the center of the project extent. If the project is more than 2 kilometer in size, the ecefLocation may represent a poor approximation of the effective cartographic projection used and a linear transformation should then be calculated at the exact origin of the data it must position. |
elements Readonly | IModelConnection.Elements | IModelConnection | The ElementStates in this IModelConnection. |
fontMap | FontMap | undefined | IModelConnection | The font map for this IModelConnection. |
geographicCoordinateSystem Accessor | undefined | GeographicCRS | IModelConnection | The geographic coordinate reference system of the iModel. |
geoServices Readonly | GeoServices | IModelConnection | The Geographic location services available for this iModelConnection. |
globalOrigin Accessor | Point3d | IModelConnection | An offset to be applied to all spatial coordinates. |
hilited Readonly | HiliteSet | IModelConnection | The set of currently hilited elements for this IModelConnection. |
isBlank Accessor ReadOnly | boolean | IModelConnection | True if this is a Blank Connection. |
isBriefcase Accessor ReadOnly | boolean | IModelConnection | Returns true if this is a briefcase copy of an iModel that is synchronized with iModelHub. |
isGeoLocated Accessor ReadOnly | boolean | IModelConnection | True if this iModel has an EcefLocation. |
isOpen Accessor ReadOnly | boolean | IModelConnection | Check if the IModelConnection is open (i.e. it has a connection to a backend server). Returns false for BlankConnection instances and after IModelConnection.close has been called. |
isReadonly Accessor ReadOnly | boolean | IModelConnection | Check the openMode of this IModelConnection to see if it was opened read-only. |
isSnapshot Accessor ReadOnly | boolean | IModelConnection | Returns true if this is a snapshot iModel. |
key Accessor ReadOnly | string | IModelConnection | Get the key that was used to open this iModel. This is the value used for Rpc and Ipc communications. |
models Readonly | IModelConnection.Models | IModelConnection | The ModelStates in this IModelConnection. |
name Accessor | string | IModelConnection | Name of the iModel |
onChangesetChanged Readonly | BeEvent<(previousChangeset: ChangesetIdWithIndex) => void> | IModelConnection | Event raised after changeset changes. |
onClose Readonly | BeEvent<(_imodel: IModelConnection) => void> | IModelConnection | Event raised immediately before this IModelConnection is closed. |
onClose Static Readonly | BeEvent<(_imodel: IModelConnection) => void> | IModelConnection | Event raised immediately before any IModelConnection is closed. |
onEcefLocationChanged Readonly | BeEvent<(previousLocation: EcefLocation) => void> | IModelConnection | Event raised after ecefLocation changes. |
onGeographicCoordinateSystemChanged Readonly | BeEvent<(previousGCS: GeographicCRS) => void> | IModelConnection | Event raised after geographicCoordinateSystem changes. |
onGlobalOriginChanged Readonly | BeEvent<(previousOrigin: Point3d) => void> | IModelConnection | Event raised after globalOrigin changes. |
onNameChanged Readonly | BeEvent<(previousName: string) => void> | IModelConnection | Event raised after name changes. |
onOpen Static Readonly | BeEvent<(_imodel: IModelConnection) => void> | IModelConnection | Event called immediately after any IModelConnection is opened. |
onProjectExtentsChanged Readonly | BeEvent<(previousExtents: Range3d) => void> | IModelConnection | Event raised after projectExtents changes. |
onRootSubjectChanged Readonly | BeEvent<(previousSubject: RootSubjectProps) => void> | IModelConnection | Event raised after rootSubject changes. |
openMode Accessor ReadOnly | OpenMode | IModelConnection | The OpenMode used for this IModel. |
projectExtents Accessor | Range3d | IModelConnection | The volume, in spatial coordinates, inside which the entire project is contained. |
repositoryModelId Static Readonly | string | IModelConnection | The Id of the repository model. |
rootSubject Accessor | RootSubjectProps | IModelConnection | The name and description of the root subject of this iModel |
rootSubjectId Static Readonly | string | IModelConnection | The Id of the root subject element. |
routingContext | IModelRoutingContext | IModelConnection | The RPC routing for this connection. |
selectionSet Readonly | SelectionSet | IModelConnection | The set of currently selected elements for this IModelConnection. |
tiles Readonly | Tiles | IModelConnection | The set of Tiles for this IModelConnection. |
transientIds Readonly | TransientIdSequence | IModelConnection | Generator for unique Ids of transient graphics for this IModelConnection. |
views Readonly | IModelConnection.Views | IModelConnection | The ViewStates in this IModelConnection. |
Defined in
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.