BriefcaseEditorToolSettings Class
Settings that can be used to control the behavior of Tools that modify a BriefcaseConnection. For example, tools that want to create new elements can consult the briefcase's editor tool settings to determine into which model and category to insert the elements. Specialized tools are free to ignore these settings.
@see - editorToolSettings to query or modify the current settings for a briefcase.
- CreateElementTool for an example of a tool that uses these settings.
Methods
Name | Description | |
---|---|---|
constructor(): BriefcaseEditorToolSettings |
Properties
Name | Type | Description | |
---|---|---|---|
category Accessor | undefined | string | The Category into which new elements should be inserted by default. | |
model Accessor | undefined | string | The Model into which new elements should be inserted by default. | |
onCategoryChanged Readonly | BeEvent<(previousCategory: string) => void> | An event raised just after the default category is changed. | |
onModelChanged Readonly | BeEvent<(previousModel: string) => void> | An event raised just after the default model is changed. |
Defined in
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.