TextureData Interface
Information about Texture data returned by queryTextureData.
Properties
Name | Type | Description | |
---|---|---|---|
bytes | Uint8Array | The encoded image bytes. | |
format | ImageSourceFormat | The format of the image (Jpeg or Png). | |
height | number | The height of the image, possibly reduced from the original height based on maxTextureSize. | |
transparency | TextureTransparency | undefined | Information about the transparency of the texture image. | |
width | number | The width of the image, possibly reduced from the original width based on maxTextureSize. |
Defined in
- core/common/src/TextureProps.ts Line 63
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.