getGeometrySummary Method
Obtain a summary of the geometry belonging to one or more GeometricElements suitable for debugging and diagnostics.
getGeometrySummary(requestProps: GeometrySummaryRequestProps): Promise<string>
@returns A string containing the summary, typically consisting of multiple lines.
@note Trying to parse the output to programmatically inspect an element's geometry is not recommended.
@see GeometryStreamIterator to more directly inspect a geometry stream.
Parameter | Type | Description |
---|---|---|
requestProps | GeometrySummaryRequestProps | Specifies the elements to query and options for how to format the output. |
Returns - Promise
A string containing the summary, typically consisting of multiple lines.
Defined in
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.