MassPropertiesResponseProps Interface
Information returned from the back end to the front end holding the result of the mass properties calculation.
Properties
Name | Type | Description | |
---|---|---|---|
area | number | undefined | Surface area of solids and surfaces when AccumulateVolumes or AccumulateAreas requested | |
centroid | XYZProps | undefined | Centroid of geometry | |
ixy | number | undefined | Product of inertia with respect to xy plane | |
ixz | number | undefined | Product of inertia with respect to xz plane | |
iyz | number | undefined | Product of inertia with respect to yz plane | |
length | number | undefined | Length of curves or perimeter of planar regions when AccumulateAreas or AccumulateLength requested | |
moments | XYZProps | undefined | Moments of inertia | |
perimeter | number | undefined | Perimeter of surfaces and planar regions when AccumulateAreas requested | |
status | BentleyStatus | Success if requested MassPropertiesOperation could be evaluated for the specified elements | |
volume | number | undefined | Volume of solids when AccumulateVolumes requested |
Defined in
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.