GeoConverter Class
An object capable of communicating with the backend to convert between coordinates in a geographic coordinate system and coordinates in an IModelConnection's own coordinate system.
@see - getConverter to obtain a converter.
- GeographicCRS for more information about geographic coordinate reference systems.
Methods
Name | Description | |
---|---|---|
convertFromIModelCoords(iModelCoords: XYZProps[]): Promise<PointWithStatus[]> | Convert the specified iModel coordinates into geographic coordinates. | |
convertToIModelCoords(geoPoints: XYZProps[]): Promise<PointWithStatus[]> | Convert the specified geographic coordinates into iModel coordinates. |
Defined in
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.