OpenBriefcaseProps Interface
Properties for opening a local briefcase file via BriefcaseDb.open
Extends
Properties
Name | Type | Description | |
---|---|---|---|
fileName Readonly | string | the full path to the briefcase file | |
readonly Readonly | boolean | undefined | If true, open the briefcase readonly. | |
watchForChanges Readonly | boolean | undefined | If true, open the briefcase readonly and monitor it for changes originating from another connection. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
key Readonly | string | undefined | OpenDbKey | |
password Readonly | string | undefined | IModelEncryptionProps | The password used to encrypt/decrypt the snapshot iModel. |
Defined in
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.