FontMap Class
A FontMap holds the set of font names available in an iModel. Within the GeometryStream of an Element, a specific font is referenced by its FontId that is local to the iModel. This class maps FontIds to FontProps.
@note The font map is generally established when the iModel is first created to specify the set of fonts available for editors. Adding new entries requires that the schema lock be held.
Methods
Name | Description | |
---|---|---|
constructor(props?: FontMapProps): FontMap | ||
addFonts(fonts: FontProps[]): void | ||
getFont(arg: string | number): undefined | FontProps | look up a font by name or number and return its FontProps | |
toJSON(): FontMapProps |
Properties
Name | Type | Description | |
---|---|---|---|
fonts Readonly | Map<number, FontProps> |
Defined in
- core/common/src/Fonts.ts Line 47
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.