EntityQueryParams Interface
Parameters for performing a query on Entity classes.
Properties
Name | Type | Description | |
---|---|---|---|
bindings | object | any[] | Bindings for parameterized values. | |
from | string | undefined | The sql className, in the form "Schema.ClassName", of the class to search. | |
limit | number | undefined | Optional "LIMIT" clause to limit the number of rows returned. | |
offset | number | undefined | Optional "OFFSET" clause. | |
only | boolean | undefined | Set to true to limit results to not include sub-classes of "from" class | |
orderBy | string | undefined | Optional "ORDERBY" clause to sort results. | |
where | string | undefined | Optional "WHERE" clause to filter entities. |
Defined in
- core/common/src/EntityProps.ts Line 53
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.