IModelRpcProps Interface
The properties that identify an opened iModel for RPC operations.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
key Readonly | string | Unique key used for identifying the iModel between the frontend and the backend |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
changeset Readonly | ChangesetIdWithIndex | undefined | IModelRpcOpenProps | Id of the last Changeset that was applied to the iModel - must be defined for briefcases that are synchronized with iModelHub. |
iModelId Readonly | string | undefined | IModelRpcOpenProps | Guid of the iModel. |
iTwinId Readonly | string | undefined | IModelRpcOpenProps | The iTwin in which the iModel exists - must be defined for briefcases that are synchronized with iModelHub. |
Defined in
- core/common/src/IModel.ts Line 39
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.