findClassFor Method
Find the first registered base class of the given EntityState className. This class will "handle" the State for the supplied className.
findClassFor<T extends >(className: string, defaultClass: T): Promise<undefined | T>
@note this method is async since it may have to query the server to get the class hierarchy.
Parameter | Type | Description |
---|---|---|
className | string | The full name of the class of interest. |
defaultClass | T | If no base class of the className is registered, return this value. |
Returns - Promise<undefined | T>
Defined in
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.