EcefLocation Class
The position and orientation of an iModel on the earth in ECEF (Earth Centered Earth Fixed) coordinates
@note This is an immutable type - all of its properties are frozen.
Implements
Methods
Name | Description | |
---|---|---|
constructor(props: EcefLocationProps): EcefLocation | Construct a new EcefLocation. | |
getTransform(): Transform | Get the transform from iModel Spatial coordinates to ECEF from this EcefLocation | |
isAlmostEqual(other: EcefLocation): boolean | Return true if this location is equivalent to another location within a small tolerance. | |
toJSON(): EcefLocationProps | ||
createFromCartographicOrigin(origin: Cartographic, point?: Point3d, angle?: Angle): EcefLocation Static | Construct ECEF Location from cartographic origin with optional known point and angle. | |
createFromTransform(transform: Transform): EcefLocation Static | Construct ECEF Location from transform with optional position on the earth used to establish the ECEF origin and orientation. |
Properties
Name | Type | Description | |
---|---|---|---|
cartographicOrigin Readonly | Cartographic | undefined | Optional position on the earth used to establish the ECEF origin and orientation. | |
earthCenter Accessor ReadOnly | Point3d | Get the location center of the earth in the iModel coordinate system. | |
orientation Readonly | YawPitchRollAngles | The orientation of the ECEF transform | |
origin Readonly | Point3d | The origin of the ECEF transform. | |
xVector Readonly | Vector3d | undefined | Optional X column vector used with yVector to calculate potentially non-rigid transform if a projection is present. | |
yVector Readonly | Vector3d | undefined | Optional Y column vector used with xVector to calculate potentially non-rigid transform if a projection is present. |
Defined in
- core/common/src/IModel.ts Line 236
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.