MassPropertiesPerCandidateResponseProps Interface
Information returned from the back end to the front end holding the result of the mass properties calculation for a single candidate.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
candidate | string |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
area | number | undefined | MassPropertiesResponseProps | Surface area of solids and surfaces when AccumulateVolumes or AccumulateAreas requested |
centroid | XYZProps | undefined | MassPropertiesResponseProps | Centroid of geometry |
ixy | number | undefined | MassPropertiesResponseProps | Product of inertia with respect to xy plane |
ixz | number | undefined | MassPropertiesResponseProps | Product of inertia with respect to xz plane |
iyz | number | undefined | MassPropertiesResponseProps | Product of inertia with respect to yz plane |
length | number | undefined | MassPropertiesResponseProps | Length of curves or perimeter of planar regions when AccumulateAreas or AccumulateLength requested |
moments | XYZProps | undefined | MassPropertiesResponseProps | Moments of inertia |
perimeter | number | undefined | MassPropertiesResponseProps | Perimeter of surfaces and planar regions when AccumulateAreas requested |
status | BentleyStatus | MassPropertiesResponseProps | Success if requested MassPropertiesOperation could be evaluated for the specified elements |
volume | number | undefined | MassPropertiesResponseProps | Volume of solids when AccumulateVolumes requested |
Defined in
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.