ElementMeshRequestProps Interface
Describes a request to generate Polyfaces from an element.
@see IModelConnection.generateElementMeshes.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
source | string | The Id of the GeometricElement from which to obtain meshes. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
angleTolerance | number | undefined | ElementMeshOptions | Maximum angle difference in radians for an approximated face. |
chordTolerance | number | undefined | ElementMeshOptions | Maximum distance from a face to the original geometry. |
minBRepFeatureSize | number | undefined | ElementMeshOptions | BRep features with bounding boxes smaller than this size will not generate graphics. |
Defined in
- core/common/src/ElementMesh.ts Line 38
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.