GeometryTileTreeReference Interface
A TileTreeReference that can supply geometry in the form of Polyfaces from Tiles belonging to its TileTree and satisfying the criteria defined by a TileGeometryCollector. Use createGeometryTreeReference to obtain a GeometryTileTreeReference from an existing TileTreeReference.
Extends
Inherited methods
Name | Inherited from | Description |
---|---|---|
_collectTileGeometry(collector: TileGeometryCollector): void Protected Inherited | TileTreeReference | A function that can be assigned to collectTileGeometry to enable geometry collection for references to tile trees that support geometry collection. |
_createGeometryTreeReference(): undefined | GeometryTileTreeReference Protected Inherited | TileTreeReference | Create a tile tree reference equivalent to this one that also supplies an implementation of collectTileGeometry. |
accumulateTransformedRange(range: Range3d, matrix: Matrix4d, frustumPlanes?: FrustumPlanes): void Inherited | TileTreeReference | |
addLogoCards(_cards: HTMLTableElement, _vp: ScreenViewport): void Inherited | TileTreeReference | Add attribution logo cards for the tile tree source logo cards to the viewport's logo div. |
addToScene(context: SceneContext): void Inherited | TileTreeReference | Adds this reference's graphics to the scene. |
canSupplyToolTip(_hit: HitDetail): boolean Inherited | TileTreeReference | Return whether this TileTreeReference can supply a tooltip describing the entity represented by the specified hit. |
collectStatistics(stats: RenderMemory.Statistics): void Inherited | TileTreeReference | Record graphics memory consumed by this tile tree reference. |
computeTransform(tree: TileTree): Transform Protected Inherited | TileTreeReference | Compute a transform from this tile tree reference's coordinate space to the IModelConnection's coordinate space. |
computeWorldContentRange(): Range3d Inherited | TileTreeReference | Compute the range of this tile tree's contents in world coordinates. |
createDrawArgs(context: SceneContext): undefined | TileDrawArgs Inherited | TileTreeReference | Create context for drawing the tile tree, if it is ready for drawing. |
createGeometryTreeReference(): undefined | GeometryTileTreeReference Inherited | TileTreeReference | Obtain a tile tree reference equivalent to this one that also supplies an implementation of collectTileGeometry, or |
decorate(_context: DecorateContext): void Inherited | TileTreeReference | Optionally add any decorations specific to this reference. |
discloseTileTrees(trees: DisclosedTileTreeSet): void Inherited | TileTreeReference | Disclose all TileTrees use by this reference. |
draw(args: TileDrawArgs): void Inherited | TileTreeReference | Adds this reference's graphics to the scene. |
getAppearanceProvider(_tree: TileTree): undefined | FeatureAppearanceProvider Protected Inherited | TileTreeReference | Return a provider that can supplement the view's symbology overrides. |
getClipVolume(tree: TileTree): undefined | RenderClipVolume Protected Inherited | TileTreeReference | Return the clip volume applied to this reference's tile tree, if any. |
getHiddenLineSettings(_tree: TileTree): undefined | HiddenLine.Settings Protected Inherited | TileTreeReference | Return hidden line settings to replace those defined for the view. |
getLocation(): undefined | Transform Inherited | TileTreeReference | Supply transform from this tile tree reference's location to iModel coordinate space. |
getSymbologyOverrides(_tree: TileTree): undefined | FeatureSymbology.Overrides Protected Inherited | TileTreeReference | Return overrides that replace any defined for the view. |
getToolTip(_hit: HitDetail): Promise<undefined | string | HTMLElement> Inherited | TileTreeReference | Return a tooltip describing the hit, or undefined if no tooltip can be supplied. |
getToolTipPromise(hit: HitDetail): undefined | Promise<undefined | string | HTMLElement> Inherited | TileTreeReference | Obtain a tooltip describing the specified hit , or undefined if this tile tree reference cannot supply a tooltip for the hit. |
getTransformFromIModel(): undefined | Transform Inherited | TileTreeReference | |
getViewFlagOverrides(tree: TileTree): Partial<Mutable<NonFunctionPropertiesOf<ViewFlags>>> Protected Inherited | TileTreeReference | Supply overrides that should be applied to the ViewState's ViewFlags when drawing this tile tree reference. |
unionFitRange(union: Range3d): void Inherited | TileTreeReference | Unions this reference's range with the supplied range to help compute a volume in world space for fitting a viewport to its contents. |
Properties
Name | Type | Description | |
---|---|---|---|
collectTileGeometry | (collector: TileGeometryCollector) => void | Populate polyfaces with geometry satisfying collector 's criteria. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
_isLoadingComplete Accessor Protected Inherited ReadOnly | boolean | TileTreeReference | Override if additional asynchronous loading is required after the tile tree is successfully loaded, to indicate when that loading has completed. |
castsShadows Accessor Inherited ReadOnly | boolean | TileTreeReference | Return whether the geometry exposed by this tile tree reference should cast shadows on other geometry. |
isGlobal Accessor Inherited ReadOnly | boolean | TileTreeReference | Return whether this reference has global coverage. Mapping data is global and some non-primary models such as the OSM building layer have global coverage |
isLoadingComplete Accessor Inherited ReadOnly | boolean | TileTreeReference | Return true if the tile tree is fully loaded and ready to draw. The default implementation returns true if the tile tree loading process completed (whether it resulted in success or failure). |
planarClipMaskPriority Accessor Inherited ReadOnly | number | TileTreeReference | The PlanarClipMaskPriority of this tile tree used to determine which tile trees contribute to a clip mask when using PlanarClipMaskMode.Priority. |
treeOwner Accessor Abstract Inherited ReadOnly | TileTreeOwner | TileTreeReference | The owner of the currently-referenced TileTree. Do not store a direct reference to it, because it may change or become disposed at any time. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.