HiddenLine.Settings Class
Describes how visible and hidden edges and transparent surfaces should be rendered in "hidden line" and "solid fill" RenderModes.
Methods
Name | Description | |
---|---|---|
equals(other: HiddenLine.Settings): boolean | ||
override(props: HiddenLine.SettingsProps): HiddenLine.Settings | Create a Settings equivalent to this one with the exception of those properties defined in the supplied JSON. | |
toJSON(): HiddenLine.SettingsProps | ||
fromJSON(json?: HiddenLine.SettingsProps): HiddenLine.Settings Static | Create a DisplaySettings from its JSON representation. |
Properties
Name | Type | Description | |
---|---|---|---|
defaults Static | HiddenLine.Settings | The default display settings. | |
hidden Readonly | HiddenLine.Style | Describes how hidden edges (those obscured by other geometry) should be displayed. | |
matchesDefaults Accessor ReadOnly | boolean | ||
transparencyThreshold Readonly | number | A value in the range [0.0, 1.0] specifying a threshold below which transparent surfaces should not be drawn. | |
transThreshold Accessor ReadOnly | number | An alias for HiddenLine.Settings.transparencyThreshold. | |
visible Readonly | HiddenLine.Style | Describes how visible edges (those unobscured by other geometry) should be displayed. |
Defined in
- core/common/src/HiddenLine.ts Line 168
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.