HiddenLine.Style Class
Describes the symbology with which edges should be drawn.
Methods
Name | Description | |
---|---|---|
equals(other: HiddenLine.Style): boolean | Returns true if this Style is equivalent to the supplied Style. | |
overrideColor(color: ColorDef): HiddenLine.Style | Create a Style equivalent to this one but with the specified color override. | |
overridePattern(pattern: LinePixels): HiddenLine.Style | Create a Style equivalent to this one but with the specified pattern override. | |
overrideWidth(width: number): HiddenLine.Style | Create a Style equivalent to this one but with the specified width override. | |
toJSON(): HiddenLine.StyleProps | ||
fromJSON(json?: HiddenLine.StyleProps, hidden?: "true"): HiddenLine.Style Static |
Properties
Name | Type | Description | |
---|---|---|---|
color Readonly | ColorDef | undefined | If defined, the color used to draw the edges. | |
defaultHidden Static Readonly | HiddenLine.Style | ||
defaultVisible Static Readonly | HiddenLine.Style | ||
pattern Readonly | LinePixels | undefined | If defined, the pixel pattern used to draw the edges. | |
width Readonly | number | undefined | If defined, the width of the edges in pixels. |
Defined in
- core/common/src/HiddenLine.ts Line 44
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.