TileTreeOwner Interface
Owns and manages the lifecycle of a TileTree. It is in turn owned by an IModelConnection.Tiles object.
@note The only legitimate way to obtain a TileTreeOwner is via getTileTreeOwner.
@see - TileTreeReference for an indirect reference to a TileTree by way of a TileTreeOwner.
- getTileTreeOwner to obtain a TileTreeOwner.
Methods
Name | Description | |
---|---|---|
load(): undefined | TileTree | If the TileTree has not yet been loaded (loadStatus is TileTreeStatus.NotLoaded), enqueue an asynchronous request to load it (changing loadStatus to Loading). | |
loadTree(): Promise<undefined | TileTree> | Waits for load, then resolves. |
Properties
Name | Type | Description | |
---|---|---|---|
iModel Readonly | IModelConnection | The iModel for this TileTree | |
loadStatus Readonly | TileTreeLoadStatus | The current load state of the tree. | |
tileTree Readonly | undefined | TileTree | The owned TileTree, or undefined if the tile tree is not loaded. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.