RenderClipVolume Class
An opaque representation of a clip volume applied to geometry within a Viewport. A RenderClipVolume is created from a ClipVector and takes ownership of that ClipVector, expecting that it will not be modified while the RenderClipVolume still references it.
@see createClipVolume to create a clip volume.
Methods
Name | Description | |
---|---|---|
constructor(clipVector: ClipVector): RenderClipVolume Protected |
Properties
Name | Type | Description | |
---|---|---|---|
clipVector Readonly | ClipVector | The ClipVector from which this volume was created. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.