SceneContext Class
Context used to create the scene to be drawn in a Viewport. The scene consists of a set of RenderGraphics produced by the TileTrees visible within the viewport. Creating the scene may result in the enqueueing of requests for Tile content which should be displayed in the viewport but are not yet loaded.
Extends
Methods
Name | Description | |
---|---|---|
constructor(vp: Viewport, frustum?: Frustum): SceneContext | ||
insertMissingTile(tile: Tile): void | Indicate that the specified tile is desired for the scene but is not yet ready. | |
outputGraphic(graphic: RenderGraphic): void | Add the specified graphic to the scene. |
Inherited methods
Name | Inherited from | Description |
---|---|---|
createBranch(branch: GraphicBranch, location: Transform): RenderGraphic Inherited | RenderContext | Create a RenderGraphic which groups a set of graphics into a node in a scene graph, applying to each a transform and optional clip volume and symbology overrides. |
createGraphicBranch(branch: GraphicBranch, location: Transform, opts?: GraphicBranchOptions): RenderGraphic Inherited | RenderContext | Create a graphic from a GraphicBranch. |
createSceneGraphicBuilder(transform?: Transform): GraphicBuilder Inherited | RenderContext | Create a builder for creating a GraphicType.Scene RenderGraphic for rendering within this context's Viewport. |
getPixelSizeAtPoint(inPoint?: Point3d): number Inherited | RenderContext | Given a point in world coordinates, determine approximately how many pixels it occupies on screen based on this context's frustum. |
Properties
Name | Type | Description | |
---|---|---|---|
backgroundGraphics Accessor ReadOnly | RenderGraphic[] | The graphics that will be drawn behind everything else in the scene. | |
graphics Accessor ReadOnly | RenderGraphic[] | The graphics in the scene that will be drawn with depth. | |
overlayGraphics Accessor ReadOnly | RenderGraphic[] | The graphics that will be drawn in front of everything else in the scene. | |
scene Readonly | Scene | The graphics comprising the scene. | |
viewingSpace Accessor ReadOnly | ViewingSpace | The viewed volume containing the scene. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
frustum Readonly Inherited | Frustum | RenderContext | Frustum extracted from the context's Viewport. |
frustumPlanes Readonly Inherited | FrustumPlanes | RenderContext | Frustum planes extracted from the context's Viewport. |
renderSystem Accessor Inherited ReadOnly | RenderSystem | RenderContext | The RenderSystem being used to produce graphics for this context. |
viewFlags Readonly Inherited | ViewFlags | RenderContext | ViewFlags extracted from the context's Viewport. |
viewport Accessor Inherited ReadOnly | Viewport | RenderContext | The Viewport associated with this context. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.