GraphicBranchOptions Interface
Options passed to createGraphicBranch.
Properties
Name | Type | Description | |
---|---|---|---|
appearanceProvider | FeatureAppearanceProvider | undefined | Supplements the view's Overrides for graphics in the branch. | |
clipVolume | RenderClipVolume | undefined | Clip applied to the graphics in the branch. | |
disableClipStyle | "true" | undefined | If true, the view's DisplayStyleSettings.clipStyle will be disabled for this branch. | |
hline | HiddenLine.Settings | undefined | Optionally replaces the view's hidden line settings when drawing the branch. | |
iModel | IModelConnection | undefined | The iModel from which the graphics originate, if different than that associated with the view. | |
transformFromIModel | Transform | undefined | An optional transform from the coordinate system of iModel to those of a different IModelConnection. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.