GraphicBranch Class
A node in a scene graph. The branch itself is not renderable. Instead it contains a list of RenderGraphics, and a transform, symbology overrides, and clip volume which are to be applied when rendering them. Branches can be nested to build an arbitrarily-complex scene graph.
@see createBranch
Implements
Methods
Name | Description | |
---|---|---|
constructor(ownsEntries: booleanfalse): GraphicBranch | Constructor | |
add(graphic: RenderGraphic): void | Add a graphic to this branch. | |
clear(): void | Empties the list of RenderGraphics contained in this branch, and if the ownsEntries flag is set, also disposes of them. | |
dispose(): void | Disposes of all graphics in this branch, if and only if ownsEntries is true. | |
getViewFlags(flags: ViewFlags): ViewFlags | Compute the view flags that result from applying this branch's viewFlagOverrides to the input flags. | |
setViewFlagOverrides(ovr: Partial<Mutable<NonFunctionPropertiesOf<ViewFlags>>>): void | Change viewFlagOverrides. | |
setViewFlags(flags: ViewFlags): void | Set viewFlagOverrides to override all ViewFlags as specified by flags . |
Properties
Name | Type | Description | |
---|---|---|---|
entries Readonly | RenderGraphic[] | The child nodes of this branch | |
isEmpty Accessor ReadOnly | boolean | Returns true if this branch contains no graphics. | |
ownsEntries Readonly | boolean | If true, when the branch is disposed of, the RenderGraphics in its entries array will also be disposed | |
realityModelDisplaySettings | RealityModelDisplaySettings | undefined | Controls how reality models are displayed within this branch. | |
symbologyOverrides | FeatureSymbology.Overrides | undefined | Optional symbology overrides to be applied to all graphics in this branch | |
viewFlagOverrides | Partial<Mutable<NonFunctionPropertiesOf<ViewFlags>>> | Selectively overrides the view's ViewFlags while drawing graphics within this branch. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.