RealityModelDisplaySettings Class
Settings that control how a reality model - whether a ContextRealityModel or a persistent reality Model - is displayed within a Viewport.
@see - displaySettings to apply these settings to a context reality model.
- setRealityModelDisplaySettings to apply these settings to a persistent reality model.
@note This is an immutable type - to modify its properties, use clone.
Methods
Name | Description | |
---|---|---|
clone(changedProps: RealityModelDisplayProps): RealityModelDisplaySettings | Create a copy of these settings, identical except for any properties explicitly specified by changedProps . |
|
equals(other: RealityModelDisplaySettings): boolean | Returns true if these settings are identical to other . |
|
toJSON(): undefined | RealityModelDisplayProps | Convert these settings to their JSON representation, which is undefined if all of their properties match the default settings. |
|
fromJSON(props?: RealityModelDisplayProps): RealityModelDisplaySettings Static | Create display settings from their JSON representation. |
Properties
Name | Type | Description | |
---|---|---|---|
defaults Static | RealityModelDisplaySettings | Settings with all properties initialized to their default values. | |
overrideColorRatio Readonly | number | If the reality model's color is overridden with another color, a ratio in [0..1] with which to mix the two colors together. | |
pointCloud Readonly | PointCloudDisplaySettings | Settings that apply specifically to point cloud reality models. |
Defined in
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.