ContextRealityModel Class
A reality model not associated with a GeometricModel but instead defined in a DisplayStyle or DisplayStyleState. Such reality models are displayed to provide context to the view and can be freely attached and detached at display time.
@see - this interactive example
- contextRealityModels to define context reality models for a display style.
Methods
Name | Description | |
---|---|---|
constructor(props: ContextRealityModelProps, options?: { createClassifiers: (container: SpatialClassifiersContainer) => SpatialClassifiers }): ContextRealityModel | Construct a new context reality model. | |
matchesNameAndUrl(name: string, url: string): boolean | Returns true if name and url match the specified name and url. | |
toJSON(): ContextRealityModelProps | Convert this model to its JSON representation. |
Properties
Name | Type | Description | |
---|---|---|---|
_appearanceOverrides Protected | FeatureAppearance | undefined | ||
_displaySettings Protected | RealityModelDisplaySettings | ||
_planarClipMask Protected | PlanarClipMaskSettings | undefined | ||
appearanceOverrides Accessor | undefined | FeatureAppearance | Overrides applied to the appearance of the reality model. | |
classifiers Accessor ReadOnly | SpatialClassifiers | A set of SpatialClassifiers, of which one at any given time can be used to classify the reality model. | |
description Readonly | string | A description of the model suitable for display in a user interface. | |
displaySettings Accessor | RealityModelDisplaySettings | Settings controlling how this reality model is displayed in a Viewport. | |
name Readonly | string | A name suitable for display in a user interface. | |
onAppearanceOverridesChanged Readonly | BeEvent<(newOverrides: FeatureAppearance, model: ContextRealityModel) => void> | Event dispatched just before assignment to appearanceOverrides. | |
onDisplaySettingsChanged Readonly | BeEvent<(newSettings: RealityModelDisplaySettings, model: ContextRealityModel) => void> | Event dispatched just before assignment to displaySettings. | |
onPlanarClipMaskChanged Readonly | BeEvent<(newSettings: PlanarClipMaskSettings, model: ContextRealityModel) => void> | Event dispatched just before assignment to planarClipMaskSettings. | |
planarClipMaskSettings Accessor | undefined | PlanarClipMaskSettings | Optionally describes how the geometry of the reality model can be masked by other models. | |
rdSourceKey Readonly | RealityDataSourceKey | undefined | The reality data source key identify the reality data provider and storage format. | |
realityDataId Readonly | string | undefined | An optional identifier that, if present, can be used to elide a request to the reality data service. | |
url Readonly | string | The URL that supplies the 3d tiles for displaying the reality model. |
Defined in
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.