PointCloudDisplaySettings Class
Settings that control how a point cloud reality model is displayed within a Viewport.
@note This is an immutable type - to modify its properties, use clone. Eye-Dome Lighting (EDL) is a non-photorealistic, image-based shading technique that was designed to improve depth perception in scientific visualization. It is particularly useful for visualizing monochrome point cloud data, but also can be useful for point clouds with color information.
@note EDL mode is ignored (off) if the view is not perspective (camera is off)
@see pointCloud.
Methods
Name | Description | |
---|---|---|
clone(changedProps: PointCloudDisplayProps): PointCloudDisplaySettings | Create a copy of these settings, identical except for any properties explicitly specified by changedProps . |
|
equals(other: PointCloudDisplaySettings): boolean | Returns true if these settings are identical to other . |
|
toJSON(): undefined | PointCloudDisplayProps | Convert these settings to their JSON representation. | |
fromJSON(props?: PointCloudDisplayProps): PointCloudDisplaySettings Static | Create display settings from their JSON representation. |
Properties
Name | Type | Description | |
---|---|---|---|
defaults Static | PointCloudDisplaySettings | Settings with all properties initialized to their default values. | |
edlFilter Readonly | number | undefined | A flag for whether or not to apply filtering pass in the Eye Dome Lighting (EDL) effect. | |
edlMixWts1 Readonly | number | undefined | A weighting value to apply to the full image when combining it with the half and quarter sized ones | |
edlMixWts2 Readonly | number | undefined | A weighting value to apply to the half sized image when combining it with the full and quarter sized ones | |
edlMixWts4 Readonly | number | undefined | A weighting value to apply to the quarter sized image when combining it with the full and half sized ones | |
edlMode Readonly | PointCloudEDLMode | The mode for the Eye-Dome Lighting (EDL) effect. | |
edlRadius Readonly | number | A radius value for the Eye Dome Lighting (EDL) effect. | |
edlStrength Readonly | number | A strength value for the Eye Dome Lighting (EDL) effect. | |
maxPixelsPerVoxel Readonly | number | If sizeMode is "voxel", the maximum radius of each point in pixels. | |
minPixelsPerVoxel Readonly | number | If sizeMode is "voxel", the minimum radius of each point in pixels. | |
pixelSize Readonly | number | The radius of each point in pixels, when sizeMode is "pixel". | |
shape Readonly | PointCloudShape | The shape drawn for each point in the cloud. | |
sizeMode Readonly | PointCloudSizeMode | The method by which the size of each individual point is computed. | |
voxelScale Readonly | number | A scale factor applied to the size of each point, when sizeMode is "voxel". |
Defined in
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.