RenderSystem Namespace
A RenderSystem provides access to resources used by the internal WebGL-based rendering system. An application rarely interacts directly with the RenderSystem; instead it interacts with types like Viewport which coordinate with the RenderSystem on the application's behalf.
Interface
Name | Description |
---|---|
RenderSystem.Options | Options passed to supplyRenderSystem to configure the RenderSystem on startup. |
Defined in
RenderSystem Class
A RenderSystem provides access to resources used by the internal WebGL-based rendering system. An application rarely interacts directly with the RenderSystem; instead it interacts with types like Viewport which coordinate with the RenderSystem on the application's behalf.
@see - Display system overview
Extended by
- MockRender.System
Implements
Methods
Name | Description | |
---|---|---|
createBatch(graphic: RenderGraphic, features: RenderFeatureTable, range: Range3d, options?: BatchOptions): RenderGraphic Abstract | Create a "batch" of graphics containing individual Features. | |
createBranch(branch: GraphicBranch, transform: Transform, options?: GraphicBranchOptions): RenderGraphic | Create a RenderGraphic consisting of a list of Graphics, with optional transform and symbology overrides applied to the list | |
createClipVolume(_clipVector: ClipVector): undefined | RenderClipVolume | Create a clip volume to clip geometry. | |
createGraphic(options: ViewportGraphicBuilderOptions | CustomGraphicBuilderOptions): GraphicBuilder Abstract | Obtain a GraphicBuilder from which to produce a RenderGraphic. | |
createGraphicBranch(branch: GraphicBranch, transform: Transform, options?: GraphicBranchOptions): RenderGraphic Abstract | Create a graphic from a GraphicBranch. | |
createGraphicBuilder(placement: Transform, type: GraphicType, viewport: Viewport, pickableId?: string): GraphicBuilder | Creates a GraphicBuilder for creating a RenderGraphic. | |
createGraphicFromDescription(args: CreateGraphicFromDescriptionArgs): undefined | RenderGraphic | Convert a GraphicDescription produced by a GraphicDescriptionBuilder into a RenderGraphic. | |
createGraphicFromTemplate(args: CreateGraphicFromTemplateArgs): RenderGraphic Abstract | Creates a graphic that draws any number of repetitions of a GraphicTemplate. | |
createGraphicList(primitives: RenderGraphic[]): RenderGraphic Abstract | Create a RenderGraphic consisting of a list of Graphics to be drawn together. | |
createGraphicOwner(ownedGraphic: RenderGraphic): RenderGraphicOwner | Create a graphic that assumes ownership of another graphic. | |
createMaterial(_params: RenderMaterial.Params, _imodel: IModelConnection): undefined | RenderMaterial | Create a RenderMaterial from parameters | Deprecated |
createRenderInstances(_params: RenderInstancesParams): undefined | RenderInstances | Create a RenderInstances from a RenderInstancesParams, to be supplied to createGraphicFromTemplate via CreateGraphicFromTempalateArgs.instances. | |
createRenderMaterial(_args: CreateRenderMaterialArgs): undefined | RenderMaterial | Create a RenderMaterial. | |
createScreenSpaceEffectBuilder(_params: ScreenSpaceEffectBuilderParams): undefined | ScreenSpaceEffectBuilder | Obtain an object capable of producing a custom screen-space effect to be applied to the image rendered by a Viewport. | |
createTemplateFromDescription(args: CreateGraphicFromDescriptionArgs): GraphicTemplate | Convert a GraphicDescription produced by a GraphicDescriptionBuilder into a GraphicTemplate. | |
createTexture(_args: CreateTextureArgs): undefined | RenderTexture | ||
createTextureFromElement(_id: string, _imodel: IModelConnection, _params: RenderTexture.Params, _format: ImageSourceFormat): undefined | RenderTexture | Create a new texture by its element ID. | |
createTextureFromImage(image: HTMLImageElement, hasAlpha: boolean, iModel: IModelConnection, params: RenderTexture.Params): undefined | RenderTexture | Create a new texture from an HTML image. | Deprecated |
createTextureFromImageBuffer(image: ImageBuffer, iModel: IModelConnection, params: RenderTexture.Params): undefined | RenderTexture | Create a new texture from an ImageBuffer. | Deprecated |
createTextureFromImageSource(source: ImageSource, iModel: IModelConnection, params: RenderTexture.Params): Promise<undefined | RenderTexture> | Create a new texture from an ImageSource. | Deprecated |
createTextureFromSource(args: CreateTextureFromSourceArgs): Promise<undefined | RenderTexture> | Create a texture from an ImageSource. | |
createWorkerGraphicDescriptionContextProps(iModel: IModelConnection): WorkerGraphicDescriptionContextProps | Obtain the JSON representation of a WorkerGraphicDescriptionContext for the specified iModel that can be forwarded to a Worker for use with a GraphicDescriptionBuilder. |
|
findMaterial(_key: string, _imodel: IModelConnection): undefined | RenderMaterial | Find a previously-created RenderMaterial by its ID. | |
findTexture(_key: TextureCacheKey, _imodel: IModelConnection): undefined | RenderTexture | Find a previously-created RenderTexture by its key. | |
getGradientTexture(_symb: Gradient.Symb, _imodel?: IModelConnection): undefined | RenderTexture | Obtain a texture created from a gradient. | |
loadTexture(id: string, iModel: IModelConnection): Promise<undefined | RenderTexture> | Find or create a RenderTexture from a persistent texture element. | |
resolveGraphicDescriptionContext(props: GraphicDescriptionContextProps, iModel: IModelConnection): Promise<GraphicDescriptionContext> | Synchronize changes made to a WorkerGraphicDescriptionContext on a Worker with the state of the iModel from which it was created. |
|
waitForAllExternalTextures(): Promise<void> | Return a Promise which when resolved indicates that all pending external textures have finished loading from the backend. | |
contextLossHandler(): Promise<any> Static | A function that is invoked after the WebGL context is lost. |
Properties
Name | Type | Description | |
---|---|---|---|
antialiasSamples | number | undefined | Antialias samples to use on all subsequently created render targets. | |
debugControl Accessor ReadOnly | undefined | RenderSystemDebugControl | Obtain an object that can be used to control various debugging features. | |
maxTextureSize Accessor ReadOnly | number | The maximum permitted width or height of a texture supported by this render system. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.