PolylineArgs Interface
Arguments supplied to createIndexedPolylines describing a set of "polylines" (i.e., line strings or point strings). Line strings consist of two or more points, connected by segments between them with a width specified in pixels. Point strings consist of one or more disconnected points, drawn as dots with a radius specified in pixels.
Properties
Name | Type | Description | |
---|---|---|---|
colors | ColorIndex | The color(s) of the vertices. | |
features | FeatureIndex | The Feature(s) contained in the polylines. | |
flags | PolylineFlags | Flags describing how to draw the polylines. | |
linePixels | LinePixels | The pixel pattern to apply to the line strings. | |
points | QPoint3dList | Point3d[] & { range: Range3d } | The positions of the polylines' vertices. | |
polylines | PolylineIndices[] | The set of polylines. | |
width | number | The width of the lines or radius of the points, in pixels. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.