FeatureIndex Class
Describes the set of Features associated with a MeshArgs or PolylineArgs. The mesh or polyline may have zero or one features; or, individual vertices may be associated with different features. The features are expressed as unsigned 32-bit integer Ids of Features within a FeatureTable.
Methods
Name | Description | |
---|---|---|
constructor(): FeatureIndex | ||
reset(): void | Reset to an empty index. |
Properties
Name | Type | Description | |
---|---|---|---|
featureID | number | If type is Uniform, the Id of the single feature. | |
featureIDs | Uint32Array | undefined | If type is NonUniform, the per-vertex feature Ids, indexed by the mesh or polyline's vertex indices. | |
isEmpty Accessor ReadOnly | boolean | True if type is FeatureIndexType.Empty. | |
isUniform Accessor ReadOnly | boolean | True if type is Uniform. | |
type | FeatureIndexType | Describes the quantity (zero, one, or more than one) of features in this index. |
Defined in
- core/common/src/FeatureIndex.ts Line 101
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.