Feature Class
Describes a discrete entity within a batched RenderGraphic that can be grouped with other such entities in a FeatureTable. Features roughly correlate to elements: a Tile's graphics combines geometry from every GeometricElement that intersects the tile's volume, so each element produces at least one feature. However, an element's geometry stream can contain geometry belonging to multiple different combinations of SubCategory and GeometryClass, so an individual element may produce more than one feature.
@see FeatureOverrides for customizing the appearance of individual features.
Methods
Name | Description | |
---|---|---|
constructor(elementId: stringId64.invalid, subCategoryId: stringId64.invalid, geometryClass: GeometryClassGeometryClass.Primary): Feature | ||
compare(rhs: Feature): number | Performs ordinal comparison of this feature with another. | |
equals(other: Feature): boolean | Returns true if this feature is equivalent to the supplied feature. |
Properties
Name | Type | Description | |
---|---|---|---|
elementId Readonly | string | ||
geometryClass Readonly | GeometryClass | ||
isDefined Accessor ReadOnly | boolean | ||
isUndefined Accessor ReadOnly | boolean | ||
subCategoryId Readonly | string |
Defined in
- core/common/src/FeatureTable.ts Line 23
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.