QPoint3dList Class
A list of QPoint3ds all quantized to the same range.
Methods
Name | Description | |
---|---|---|
constructor(params?: QParams3d): QPoint3dList | Construct an empty list set up to quantize to the supplied range. | |
[iterator](): ArrayIterator<QPoint3d> | An iterator over the points in the list. | |
add(pt: Point3d): void | Quantizes the supplied Point3d to this list's range and appends it to the list. | |
clear(): void | Removes all points from the list. | |
fromTypedArray(range: Range3d, array: Uint16Array): void | Reinitialize from a Uint16Array in which the first three elements specify the x, y, and z components of the first point, the second three elements specify the components | |
push(qpt: QPoint3d): void | Adds a previously-quantized point to this list. | |
requantize(params: QParams3d): void | Changes the quantization parameters and requantizes all points in the list to the new range. | |
reset(params: QParams3d): void | Clears out the contents of the list and changes the quantization parameters. | |
toTypedArray(): Uint16Array | Extracts the current contents of the list as a Uint16Array such that the first 3 elements contain the first point's x, y, and z components, | |
unquantize(index: number, out?: Point3d): Point3d | Returns the unquantized value of the point at the specified index in the list. | |
createFrom(points: Point3d[], params: QParams3d): QPoint3dList Static | Construct a list containing all points in the supplied list, quantized using the supplied parameters. | |
fromPoints(points: Point3d[], out?: QPoint3dList): QPoint3dList Static | Construct a QPoint3dList containing all points in the supplied list, quantized to the range of those points. |
Properties
Name | Type | Description | |
---|---|---|---|
length Accessor ReadOnly | number | The number of points in the list. | |
list Accessor ReadOnly | ReadonlyArray<QPoint3d> | The list of quantized points. | |
params Readonly | QParams3d | Parameters used to quantize the points. |
Defined in
- core/common/src/QPoint.ts Line 735
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.