BatchOptions Interface
Options used when constructing a Batch
- that is, a RenderGraphic with an associated FeatureTable describing individual Features within the
graphic. Individual features can be resymbolized in a variety of ways including flashing and hiliting.
For example, to prevent graphics produced by readElementGraphics from being hilited when their corresponding element is in the SelectionSet,
pass { noHilite: true }
to readElementGraphics.
Properties
Name | Type | Description | |
---|---|---|---|
locateOnly | boolean | undefined | If true, the contents of the batch will only be drawn by readPixels, not renderFrame, causing them to be locatable but invisible. | |
noEmphasis | boolean | undefined | If true, features within the batch will not be emphasized when the corresponding Feature is emphasized using FeatureOverrides. | |
noFlash | boolean | undefined | If true, features within the batch will not be flashed on mouseover. | |
noHilite | boolean | undefined | If true, features within the batch will not be hilited when their corresponding element is in the SelectionSet. | |
tileId | string | undefined | Identifies the Tile associated with the batch, chiefly for debugging purposes. |
Defined in
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.